Project

Profile

Help

Issue #4471

Pulp returns 200 when it fails to create rpm content

Added by daviddavis almost 3 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 49
Quarter:

Description

Steps to reproduce:

$ echo "blah" > foo-4.1-1.noarch.rpm
$ http --form POST http://localhost:8000/pulp/api/v3/artifacts/ file@./foo-4.1-1.noarch.rpm
$ http POST http://localhost:8000/pulp/api/v3/content/rpm/packages/ relative_path=foo.rpm _artifact="/pulp/api/v3/artifacts/1/" filename=foo-4.1-1.noarch.rpm

The response correctly shows an error ("RPM file cannot be parsed for metadata.") but the http status code is 200.


Related issues

Copied to RPM Support - Issue #4537: Pulp returns 200 when it fails to create rpm contentCLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 786308c8 View on GitHub
Added by ppicka almost 3 years ago

Change return status

When RPM file is not parsable return 406 (Not Acceptable) as rpm cannot be accepted due to metadata parse failed.

closes: #4471 https://pulp.plan.io/issues/4471

Signed-off-by: Pavel Picka

History

#1 Updated by ppicka almost 3 years ago

  • Assignee set to ppicka

#2 Updated by ppicka almost 3 years ago

  • Status changed from NEW to POST

#3 Updated by ppicka almost 3 years ago

  • Status changed from POST to MODIFIED

#4 Updated by ipanova@redhat.com almost 3 years ago

  • Sprint set to Sprint 49

#5 Updated by ttereshc almost 3 years ago

  • Triaged changed from No to Yes

#6 Updated by bherring over 2 years ago

  • Copied to Issue #4537: Pulp returns 200 when it fails to create rpm content added

#7 Updated by bmbouter over 2 years ago

  • Tags deleted (Pulp 3)

#8 Updated by ttereshc almost 2 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF