Project

Profile

Help

Issue #447

The Pulp RPM CLI doesn't tell users they can install RPMs by epoch, version, release, and architecture

Added by pthomas@redhat.com over 6 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Cloning this bug since these options can not be specified though the cli

++ This bug was initially created as a clone of Bug #1004981 ++

Our API offers users the ability to request units to be installed on consumers using the full NEVRA information, but the agent handler for RPM content only considers the name when installing packages. This could be surprising to some of our users, who might have provided a specific version that wasn't the latest available version of a package to be installed on a consumer.

--- Additional comment from Barnaby Court on 2013-11-05 10:54:00 EST ---

PR: https://github.com/pulp/pulp_rpm/pull/374

--- Additional comment from Jeff Ortel on 2014-04-03 09:36:17 EDT ---

build: 2.4.0-0.7.beta

--- Additional comment from Preethi Thomas on 2014-06-04 11:04:36 EDT ---

verified
[root@hp-dl380pgen8-01 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.19.beta.fc20.noarch
[root@hp-dl380pgen8-01 ~]#

The options are available in API

In [24]: pic.POST ('/v2/consumers/kitkat/actions/content/install/',body={'units':[{'unit_key':{'name':'whale','version':'0.2'},'type_id':'rpm'}], 'options':{} })
Request Body
{
"units": [
{
"unit_key": {
"version": "0.2",
"name": "whale"
},
"type_id": "rpm"
}
],
"options": {}
}
Response Body
{
"spawned_tasks": [
{
"_href": "/pulp/api/v2/tasks/0357aa3b-e4cf-4dba-ac04-48ed3ebf114c/",
"task_id": "0357aa3b-e4cf-4dba-ac04-48ed3ebf114c"
}
],
"result": null,
"error": null
}
Out[24]:
(202,
{u'error': None,
u'result': None,
u'spawned_tasks': [{u'_href': u'/pulp/api/v2/tasks/0357aa3b-e4cf-4dba-ac04-48ed3ebf114c/',
u'task_id': u'0357aa3b-e4cf-4dba-ac04-48ed3ebf114c'}]})

In [25]:

In [17]: pic.POST ('/v2/consumers/kitkat/actions/content/install/',body={'units':[{'unit_key':{'name':'zebra','epoch':'0'},'type_id':'rpm'}], 'options':{} })
Request Body
{
"units": [
{
"unit_key": {
"epoch": "0",
"name": "zebra"
},
"type_id": "rpm"
}
],
"options": {}
}
Response Body
{
"spawned_tasks": [
{
"_href": "/pulp/api/v2/tasks/c2f3081e-89fb-4ca6-8ce1-cfc67834cbbc/",
"task_id": "c2f3081e-89fb-4ca6-8ce1-cfc67834cbbc"
}
],
"result": null,
"error": null
}
Out[17]:
(202,
{u'error': None,
u'result': None,
u'spawned_tasks': [{u'_href': u'/pulp/api/v2/tasks/c2f3081e-89fb-4ca6-8ce1-cfc67834cbbc/',
u'task_id': u'c2f3081e-89fb-4ca6-8ce1-cfc67834cbbc'}]})

+ This bug was cloned from Bugzilla Bug #1104742 +

History

#1 Updated by pthomas@redhat.com over 6 years ago

[root@hp-dl380pgen8-01 ~]# pulp-admin rpm consumer package install run --consumer-id kitkat
Command: run
Description: triggers an immediate package install on a consumer

Available Arguments:

--bg          - if specified, the client process will end immediately (the
                task will continue to run on the server)
--consumer-id - (required) unique identifier; only alphanumeric, ., -, and _
                allowed
--name, -n    - (required) package name; may repeat for multiple packages
--no-commit   - test the transaction without committing it
--reboot      - reboot after a successful transaction
--import-keys - import GPG keys as needed
The following options are required but were not specified:
--name
[root@hp-dl380pgen8-01 ~]#

+ This comment was cloned from Bugzilla #1104742 comment 1 +

#2 Updated by rbarlow over 6 years ago

The CLI is not meant to have these features, but we could update the helptext on the --name flag to mention that users can put version, release, etc.

+ This comment was cloned from Bugzilla #1104742 comment 2 +

#3 Updated by bmbouter over 6 years ago

  • Severity changed from Low to 1. Low

#4 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#5 Updated by bmbouter over 2 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#6 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF