Project

Profile

Help

Issue #444

traceback in the log when syncing repo feed file:///

Added by pthomas@redhat.com almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Low
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4 Beta
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
traceback in the log when syncing repo feed file:///

Version-Release number of selected component (if applicable):
[root@hp-dl380pgen8-01 tmp]# rpm -qa pulp-server
pulp-server-2.4.0-0.19.beta.fc20.noarch
[root@hp-dl380pgen8-01 tmp]#

How reproducible:

Steps to Reproduce:
1. create a repo with --feed file:///
2. sync the repo and trace the log
3.

Actual results:

[root@hp-dl380pgen8-01 tmp]# pulp-admin rpm repo create --repo-id local --feed file:///tmp/local-repo/
Successfully created repository [local]

[root@hp-dl380pgen8-01 tmp]# pulp-admin rpm repo sync run --repo-id local+----------------------------------------------------------------------+
Synchronizing Repository [local]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[-]
... completed

Downloading repository content...
[==================================================] 100%
RPMs: 3/3 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Task Succeeded

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
3 of 3 items
... completed

Publishing Delta RPMs
[-]
... completed

Publishing Errata
[-]
... completed

Publishing Comps file
[-]
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

Additional info:
celery.worker.job:INFO: Task pulp.server.async.tasks._reserve_resource[8ca2d651-418f-4a12-bcad-96141ea1b3f9] succeeded in 0.0409486019635s:
celery.worker.strategy:INFO: Received task: pulp.server.tasks.repository.sync_with_auto_publish[2a5f8925-7132-4fa7-81d0-c151bc936602]
celery.worker.strategy:INFO: Received task: pulp.server.async.tasks._queue_release_resource[3b7b7eb3-b370-4dc8-9ea3-893b84f0b184]
pulp_rpm.plugins.importers.yum.sync:INFO: Downloading metadata from file:///tmp/local-repo/.
pulp_rpm.plugins.importers.yum.sync:INFO: Generating metadata databases.
pulp_rpm.plugins.importers.yum.sync:INFO: Determining which units need to be downloaded.
pulp_rpm.plugins.importers.yum.sync:INFO: Downloading 3 RPMs.
pulp_rpm.plugins.importers.yum.sync:INFO: Downloading additional units.
nectar.downloaders.local:ERROR: [Errno 2] No such file or directory: u'///tmp/local-repo/.treeinfo'
nectar.downloaders.local:ERROR: Traceback (most recent call last):
nectar.downloaders.local:ERROR: File "/usr/lib/python2.7/site-packages/nectar/downloaders/local.py", line 131, in _copy
nectar.downloaders.local:ERROR: src_handle = open(src_path, 'rb')
nectar.downloaders.local:ERROR: IOError: [Errno 2] No such file or directory: u'///tmp/local-repo/.treeinfo'
nectar.downloaders.local:ERROR: [Errno 2] No such file or directory: u'///tmp/local-repo/treeinfo'
nectar.downloaders.local:ERROR: Traceback (most recent call last):
nectar.downloaders.local:ERROR: File "/usr/lib/python2.7/site-packages/nectar/downloaders/local.py", line 131, in _copy
nectar.downloaders.local:ERROR: src_handle = open(src_path, 'rb')
nectar.downloaders.local:ERROR: IOError: [Errno 2] No such file or directory: u'///tmp/local-repo/treeinfo'
pulp_rpm.plugins.importers.yum.sync:INFO: Sync complete.
celery.worker.strategy:INFO: Received task: pulp.server.async.tasks._reserve_resource[9c63bb5a-40cb-41fe-9e61-c5dedeaa46fe]
celery.worker.job:INFO: Task pulp.server.async.tasks._reserve_resource[9c63bb5a-40cb-41fe-9e61-c5dedeaa46fe] succeeded in 0.0412268069922s:
celery.worker.strategy:INFO: Received task: pulp.server.managers.repo.publish.publish[e831dabe-bf8d-4eba-8166-c4e20a3b7cec]
celery.worker.job:INFO: Task pulp.server.tasks.repository.sync_with_auto_publish[2a5f8925-7132-4fa7-81d0-c151bc936602] succeeded in 0.595084420987s: <pulp.server.async.tasks.TaskResult object at 0x3a50690>

+ This bug was cloned from Bugzilla Bug #1103842 +

History

#2 Updated by cduryee almost 7 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1103842 comment 2 +

#3 Updated by pthomas@redhat.com almost 7 years ago

[root@gizmo ~]# rpm -qa pulp-server
pulp-server-2.6.0-0.5.beta.el6.noarch
[root@gizmo ~]#

[root@gizmo ~]# pulp-admin rpm repo create --repo-id local --feed file:///var/lib/pulp/published/yum/https/repos/repos/pulp/pulp/demo_repos/zoo/
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

Successfully created repository [local]

[root@gizmo ~]#
[root@gizmo ~]#
[root@gizmo ~]#
[root@gizmo ~]# pulp-admin rpm repo sync run --repo-id local
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

--------------------------------------------------------------------
Synchronizing Repository [local]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[-]
... completed

Downloading repository content...
[==================================================] 100%
RPMs: 0/0 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Task Succeeded

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
32 of 32 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[==================================================] 100%
4 of 4 items
... completed

Publishing Comps file
[==================================================] 100%
3 of 3 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

[root@gizmo ~]#

+ This comment was cloned from Bugzilla #1103842 comment 3 +

#4 Updated by bmbouter almost 7 years ago

  • Severity changed from Medium to 2. Medium

#5 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#7 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF