Project

Profile

Help

Issue #443

closed

pulp.server.managers.event.remote requires qpid.messaging

Added by rbarlow almost 8 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I noticed today that pulp.server.managers.event.remote has these two import statements:

16 from qpid.messaging import Connection
17 from qpid.messaging.exceptions import ConnectionError, MessagingError

I believe we should strive to be message broker agnostic as an upstream project, so we should not require qpid.messaging. Here are two suggested fixes:

1) It has been proposed that we could simply remove the feature provided by this module. It may not be very useful, especially since users can now monitor Celery tasks.

2) We could rework this module to use Kombu for message broker abstraction.

I would like to suggest that we make this low priority on 2.4. It's not a regression, since we didn't support rabbitmq in 2.3. It would be nice though since we are trying to allow users to choose rabbitmq for 2.4.

+ This bug was cloned from Bugzilla Bug #1103354 +

Actions #1

Updated by rbarlow almost 8 years ago

I think this one is more of a defect than a task, since it is the only element of Pulp that actually does require a Qpid dependency. For Rabbit users this would be annoying.

It could be argued as a feature too I suppose since it's about supporting Rabbit with our event system.

+ This comment was cloned from Bugzilla #1103354 comment 1 +

Actions #2

Updated by bmbouter over 7 years ago

  • Severity changed from Medium to 2. Medium
Actions #3

Updated by bmbouter over 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX
Actions #4

Updated by bmbouter over 3 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

Actions #5

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added
Actions #6

Updated by bmbouter over 2 years ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Also available in: Atom PDF