Project

Profile

Help

Issue #440

Restarting Pulp after changing concurrency left stale workers

Added by akrzos@redhat.com almost 5 years ago. Updated 9 months ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
1. Low
Version:
2.4.0
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Description of problem:
Change PULP_CONCURRENCY in /etc/default/pulp_workers prior to restarting pulp_resource_manager, pulp_workers, pulp_celerybeat has left several stale workers on my machine.

Version-Release number of selected component (if applicable):
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-puppet-tools-2.4.0-0.18.beta.el6sat.noarch
m2crypto-0.21.1.pulp-10.el6sat.x86_64
pulp-rpm-plugins-2.4.0-0.18.beta.el6sat.noarch
pulp-katello-plugins-0.3-1.el6sat.noarch
python-pulp-rpm-common-2.4.0-0.18.beta.el6sat.noarch
python-pulp-bindings-2.4.0-0.18.beta.el6sat.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
python-pulp-common-2.4.0-0.18.beta.el6sat.noarch
pulp-server-2.4.0-0.18.beta.el6sat.noarch
pulp-nodes-parent-2.4.0-0.18.beta.el6sat.noarch
pulp-nodes-common-2.4.0-0.18.beta.el6sat.noarch
pulp-selinux-2.4.0-0.18.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-pulp-puppet-common-2.4.0-0.18.beta.el6sat.noarch
python-kombu-3.0.15-5.pulp.el6sat.noarch
pulp-puppet-plugins-2.4.0-0.18.beta.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. change PULP_CONCURRENCY to < available cores on machine in /etc/default/pulp_workers while pulp is running
2. service pulp_resource_manager restart; service pulp_workers restart; service pulp_celerybeat restart;
3. view processes to see if stale processes remain

Actual results:
Pulp only stops and restarts the number of workers as set to PULP_CONCURRENCY.

Expected results:
Pulp should stop all Pulp workers and start only the number specified in PULP_CONCURRENCY or if the value is commented out then the default.

Additional info:

+ This bug was cloned from Bugzilla Bug #1102369 +

History

#1 Updated by dgregor@redhat.com almost 5 years ago

Just ran into this myself as well.

+ This comment was cloned from Bugzilla #1102369 comment 1 +

#2 Updated by bmbouter almost 5 years ago

  • Severity changed from Low to 1. Low

#3 Updated by bmbouter about 4 years ago

A valid workaround to this issue is to:

1) stop pulp services
2) modify PULP_CONCURRENCY
3) start pulp processes

This will leave no stale processes because they were all stopped in step (1)

#4 Updated by bmbouter 9 months ago

  • Status changed from NEW to CLOSED - WONTFIX

#5 Updated by bmbouter 9 months ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#6 Updated by bmbouter 9 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF