Project

Profile

Help

Story #4229

Create yum repos with simple-md-filenames createrepo setting

Added by vpapalia almost 2 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When creating a new yum repo, for metadata it appears pulp just uses default settings of --unique-md-filenames which prefixes metadata files with their checksum. We have a requirement to override this setting with --simple-md-filenames which will create metadata files without being prefixed with the files checksum. From searching it doesn't appear possible?

History

#1 Updated by ttereshc almost 2 years ago

  • Project changed from Pulp to RPM Support

To my knowledge, it is not configurable, Pulp generates repodata files prefixed with checksums.

Can you elaborate on your use case, please? When is it important to have filenames without checksum as a prefix? What is the downside of prefixed filenames?

FWIW, prefixed filenames help with caching (you never have outdated cache) and it gives ability to have old repodata files in the directory if needed.

#2 Updated by vpapalia almost 2 years ago

Our use case is we have standalone pulp repos distributed globally (so separate httpd, mongo etc) and want to use another region's pulp as a failover if the local pulp falls over. THe problem is given metadata has different filenames you'll get a 404 on the metadata in this case since it'll try to look for the metadata from one region in the other region, but with prefixed checksums these are unique and wont exist in other region.

Thanks!

#3 Updated by CodeHeeler almost 2 years ago

  • Tracker changed from Issue to Story
  • % Done set to 0

#4 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF