Project

Profile

Help

Issue #4223

Unable to install pulp from https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7Server/x86_64/

Added by jluza about 1 year ago. Updated 10 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Deps for pulp-server-2.17.1-1.el7.noarch.rpm:

jluza@unused ~/github $ # rpm -qR pulp-server-2.17.1-1.el7.noarch.rpm 
warning: pulp-server-2.17.1-1.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
...
python(abi) = 2.7
python-blinker
python-celery >= 4.0.0
python-django >= 1.8.0
...

However then I donwload https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7Server/x86_64/python2-celery-4.0.2-5.el7.noarch.rpm

I can see

jluza@unused ~/github $ # rpm --provides -qp python2-celery-4.0.2-5.el7.noarch.rpm 
warning: python2-celery-4.0.2-5.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-celery
python2-celery = 4.0.2-5.el7

compared to package provided by fedora:

jluza@unused ~/github $ # rpm --provides -qp python2-celery-4.0.2-7.fc28.noarch.rpm
python-celery = 4.0.2-7.fc28
python2-celery = 4.0.2-7.fc28
python2.7dist(celery) = 4.0.2
python2dist(celery) = 4.0.2

History

#1 Updated by pcreech about 1 year ago

So, I looked at all the python2* packages we are currently distributing, and this is what I came up with:

[root@koji x86_64]# rpm --provides -qp python2-amqp-2.2.2-3.el7.noarch.rpm 
warning: python2-amqp-2.2.2-3.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-amqp
python2-amqp = 2.2.2-3.el7
[root@koji x86_64]# rpm --provides -qp python2-billiard-3.5.0.3-3.el7.x86_64.rpm 
warning: python2-billiard-3.5.0.3-3.el7.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-billiard
python2-billiard = 1:3.5.0.3-3.el7
python2-billiard(x86-64) = 1:3.5.0.3-3.el7
[root@koji x86_64]# rpm --provides -qp python2-celery-4.0.2-5.el7.noarch.rpm 
warning: python2-celery-4.0.2-5.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-celery
python2-celery = 4.0.2-5.el7
[root@koji x86_64]# rpm --provides -qp python2-debpkgr-1.1.0-1.el7.noarch.rpm 
warning: python2-debpkgr-1.1.0-1.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-debpkgr
python2-debpkgr = 1.1.0-1.el7
[root@koji x86_64]# rpm --provides -qp python2-django-1.11.13-1.el7.noarch.rpm 
warning: python2-django-1.11.13-1.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
Django = 1.11.13-1.el7
bundled(jquery) = 2.2.3
bundled(xregexp) = 2.0.0
django = 1.11.13-1.el7
python-django
python2-django = 1.11.13-1.el7
[root@koji x86_64]# rpm --provides -qp python2-kombu-4.0.2-9.el7.noarch.rpm 
warning: python2-kombu-4.0.2-9.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-kombu
python2-kombu = 1:4.0.2-9.el7
[root@koji x86_64]# rpm --provides -qp python2-solv-0.6.34-2.pulp.el7.x86_64.rpm 
warning: python2-solv-0.6.34-2.pulp.el7.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-solv = 0.6.34-2.pulp.el7
python-solv(x86-64) = 0.6.34-2.pulp.el7
python2-solv = 0.6.34-2.pulp.el7
python2-solv(x86-64) = 0.6.34-2.pulp.el7
[root@koji x86_64]# rpm --provides -qp python2-vine-1.1.3-4.el7.noarch.rpm 
warning: python2-vine-1.1.3-4.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
python-vine
python2-vine = 1.1.3-4.el7

These spec files were taken verbatim from fedora and rebuilt against our el7 buildroots in koji.katello.org

We unfortunately haven't seen this issue ourselves on any el7 platforms, so can you explain your install workflow a little bit, to hopefully help narrow down what is causing this to trip up an install?

#2 Updated by jluza about 1 year ago

Today I tried to reproduce on centos 7 but I wasn't able to. I guess problem was related only to puppet deployed. Please feel free to close this as Can't reproduce

#3 Updated by amacdona@redhat.com about 1 year ago

  • Status changed from NEW to CLOSED - NOTABUG

#4 Updated by bmbouter 10 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF