Project

Profile

Help

Issue #407

Needs better error handling when the specified relative-url is already used for another repo

Added by pthomas@redhat.com almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.0
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

Needs better error handling when the specified relative-url is already used for another repo.

Version-Release number of selected component (if applicable):

[root@cloud-qe-9 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.6.alpha.fc20.noarch
[root@cloud-qe-9 ~]#
How reproducible:

Steps to Reproduce:
1. Create repo with --relative-url of another repo
2.
3.

Actual results:

[root@cloud-qe-9 ~]# pulp-admin rpm repo create --repo-id pulp --feed http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/pulp_unittest/ --relative-url scientific
The server indicated one or more values were incorrect. The server provided the
following error message:

Pulp exception occurred: PulpDataException

More information can be found in the client log file ~/.pulp/admin.log.
Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1079511 +

History

#1 Updated by amacdona@redhat.com almost 7 years ago

Some strange behavior here. It looks like the repo does not claim the namespace of its relative-url, but it does claims the namespace of its repo-id.

± pulp-admin rpm repo create --repo-id=zoo2 --relative-url=zoo \
--feed=http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
Successfully created repository [zoo2]

No problem creating a second repo with the same url

± pulp-admin rpm repo create --repo-id=zoo3 --relative-url=zoo \
--feed=http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
Successfully created repository [zoo3]

The issue shows up here because the the relative-url has already been claimed by the repo-id of the first.

± pulp-admin rpm repo create --repo-id=anything --relative-url=zoo2 \
--feed=http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
The server indicated one or more values were incorrect. The server provided the
following error message:

Pulp exception occurred: PulpDataException

More information can be found in the client log file ~/.pulp/admin.log.

+ This comment was cloned from Bugzilla #1079511 comment 1 +

#3 Updated by cduryee almost 7 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1079511 comment 3 +

#4 Updated by igulina@redhat.com almost 7 years ago

rpm -qa pulp-server

pulp-server-2.6.0-0.2.beta.el6.noarch

pulp-admin rpm repo create --repo-id repo1 --relative-url repo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/horse-0.22-2.noarch.rpm

Successfully created repository [repo1]

pulp-admin rpm repo create --repo-id repo2 --relative-url repo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/zebra-0.1-2.noarch.rpm

The server indicated one or more values were incorrect. The server provided the
following error message:

Relative URL [repo] for repository [repo2] conflicts with existing relative
URL [repo] for repository [repo1]

More information can be found in the client log file ~/.pulp/admin.log.

+ This comment was cloned from Bugzilla #1079511 comment 4 +

#5 Updated by bmbouter almost 7 years ago

  • Severity changed from Medium to 2. Medium

#6 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF