Project

Profile

Help

Issue #4024

Collection name in the errata update element shows repo id

Added by ragbalak about 3 years ago. Updated over 2 years ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

On testing https://github.com/PulpQE/Pulp-2-Tests/issues/94
`check that each collection name is unique beneath the update element i.e the name has a <module_name><arbitrary increasing number> suffix `

Steps followed:

Create a repo with the modules rpm feed url (https://repos.fedorapeople.org/pulp/pulp/fixtures/rpm-with-modules)
Sync and publish the repo
Go to the publishes repo with /pulp/repos/', distributor['config']['relative_url']
I used the get_repodata fromutils `Pulp-2-Tests/pulp_2_tests/tests/rpm/api_v2/utils.py`
The xml of the published repo, contained the repo_id in the short field rather than `_<module_name>_<arbitrary increasing number>`

This is tested in

NAME=Fedora
VERSION="28 (Server Edition)"
ID=fedora
VERSION_ID=28
PLATFORM_ID="platform:f28"
PRETTY_NAME="Fedora 28 (Server Edition)"
ANSI_COLOR="0;34"
CPE_NAME="cpe:/o:fedoraproject:fedora:28"
HOME_URL="https://fedoraproject.org/"
SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=28
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=28
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Server Edition"
VARIANT_ID=server

The pulp version is

pulp-admin-client-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
pulp-deb-admin-extensions-1.8.0-0.1.alpha.201809170522git92d79cf.fc28.noarch
pulp-deb-plugins-1.8.0-0.1.alpha.201809170522git92d79cf.fc28.noarch
pulp-docker-admin-extensions-3.3.0-0.1.alpha.201809170501git0c5d136.fc28.noarch
pulp-docker-plugins-3.3.0-0.1.alpha.201809170501git0c5d136.fc28.noarch
pulp-ostree-admin-extensions-1.4.0-0.1.alpha.201809170503git2c2d534.fc28.noarch
pulp-ostree-plugins-1.4.0-0.1.alpha.201809170503git2c2d534.fc28.noarch
pulp-puppet-admin-extensions-2.18.0-0.1.alpha.201809170505git44a02f8.fc28.noarch
pulp-puppet-plugins-2.18.0-0.1.alpha.201809170505git44a02f8.fc28.noarch
pulp-puppet-tools-2.18.0-0.1.alpha.201809170505git44a02f8.fc28.noarch
pulp-python-admin-extensions-2.1.0-0.1.alpha.201809170459git5e2aa35.fc28.noarch
pulp-python-plugins-2.1.0-0.1.alpha.201809170459git5e2aa35.fc28.noarch
pulp-rpm-admin-extensions-2.18.0-0.1.alpha.201809170509gitdd4651f.fc28.noarch
pulp-rpm-plugins-2.18.0-0.1.alpha.201809170509gitdd4651f.fc28.noarch
pulp-selinux-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
pulp-server-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
python-pulp-bindings-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
python-pulp-client-lib-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
python-pulp-common-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
python-pulp-deb-common-1.8.0-0.1.alpha.201809170522git92d79cf.fc28.noarch
python-pulp-docker-common-3.3.0-0.1.alpha.201809170501git0c5d136.fc28.noarch
python-pulp-oid_validation-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
python-pulp-ostree-common-1.4.0-0.1.alpha.201809170503git2c2d534.fc28.noarch
python-pulp-puppet-common-2.18.0-0.1.alpha.201809170505git44a02f8.fc28.noarch
python-pulp-python-common-2.1.0-0.1.alpha.201809170459git5e2aa35.fc28.noarch
python-pulp-repoauth-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch
python-pulp-rpm-common-2.18.0-0.1.alpha.201809170509gitdd4651f.fc28.noarch
python-pulp-streamer-2.18.0-0.1.alpha.201809170514git0370701.fc28.noarch

Please find attached the published repo update list

output.txt (5.06 KB) output.txt ragbalak, 09/18/2018 01:12 AM

History

#1 Updated by ragbalak about 3 years ago

  • Description updated (diff)

#2 Updated by ragbalak about 3 years ago

  • Description updated (diff)

#3 Updated by ttereshc about 3 years ago

That seems correct to me.
It's important to have a repo_id in the collection name. It's a way to guarantee that collection name is unique for the same errata_id accross multiple repositories.

I propose to close as not a bug.

#4 Updated by ttereshc about 3 years ago

ragbalak, did you test it with the PR https://github.com/pulp/pulp_rpm/pull/1173 ? It's not merged yet.

#5 Updated by ttereshc about 3 years ago

  • Project changed from Pulp to RPM Support

#6 Updated by ragbalak about 3 years ago

Hi Team,

Have tested and verified this after pulling changes from https://github.com/pulp/pulp_rpm/pull/1173.
Currently, the collection names are appearing as follows: <repo_id>_<arbitrary increasing number>_<default/module_name>.

The keyword `default` appears in the above format for ursine RPMs.

Thanks!

#7 Updated by ttereshc about 3 years ago

  • Status changed from NEW to CLOSED - NOTABUG

'default' is for non-modular ones, that's correct.
Thanks for testing, I'm closing it as notabug.

#8 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF