Project

Profile

Help

Issue #398

goferd doesn't log failures

Added by chris.a.st.pierre@gmail.com almost 7 years ago. Updated about 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.3
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

If goferd cannot authenticate to the parent, it fails silently unless you run it in the foreground.

Version-Release number of selected component (if applicable):

pulp-agent-2.3.1-1.el6.noarch
python-pulp-agent-lib-2.3.1-1.el6.noarch
gofer-0.77.1-1.el6.noarch
python-gofer-0.77.1-1.el6.noarch

How reproducible:

Always.

Steps to Reproduce:
1. Break authentication on the parent. I believe it should be sufficient to disable OAuth.
2. Start goferd on the child.
3. Be puzzled about why things aren't working.

Actual results:

goferd silently fails to authenticate and syncs time out with no explanation of why.

Expected results:

goferd should log the detailed and useful error message it produces when run in the foreground. (For extra points, a more useful message about where to look when a sync times out would be awful nice, too.)

Additional info:

+ This bug was cloned from Bugzilla Bug #1065367 +

History

#1 Updated by chris.a.st.pierre@gmail.com almost 7 years ago

It turns out that my ultimate problem was this: https://bugzilla.redhat.com/show_bug.cgi?id=834697

So it'd be extra super nice if goferd caught this exception and logged something friendly about disabling qpidd authentication:

Exception in thread ip-10-196-7-184.poc.ae1.mclassdc.net:
Traceback (most recent call last):
File "/usr/lib64/python2.6/threading.py", line 532, in _bootstrap_inner
self.run()
File "/usr/lib/python2.6/site-packages/gofer/messaging/consumer.py", line 61, in run
receiver = self.
_open()
File "/usr/lib/python2.6/site-packages/gofer/messaging/consumer.py", line 89, in _open
ssn = self.
_consumer.session()
File "/usr/lib/python2.6/site-packages/gofer/messaging/endpoint.py", line 186, in session
self.__session = self.ssnpool.get(self.url)
File "/usr/lib/python2.6/site-packages/gofer/messaging/endpoint.py", line 54, in get
con = broker.connect()
File "/usr/lib/python2.6/site-packages/gofer/messaging/broker.py", line 108, in connect
con.attach()
File "<string>", line 6, in attach
File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 274, in attach
self._ewait(lambda: self._transport_connected and not self._unlinked())
File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 209, in _ewait
self.check_error()
File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 202, in check_error
raise self.error
AuthenticationFailure: Error in sasl_client_start (-1) SASL (-1): generic failure: GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Credentials cache file '/tmp/krb5cc_0' not found)

As it stands, the error, which is largely impenetrable, is also hidden.

+ This comment was cloned from Bugzilla #1065367 comment 1 +

#2 Updated by bmbouter over 6 years ago

  • Severity changed from Low to 1. Low

#3 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#4 Updated by bmbouter over 2 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF