Project

Profile

Help

Issue #3920

Artifact files are created as truncated or partial files when the worker is termineated during a sync.

Added by jortel@redhat.com over 2 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The termination (or restart) of the worker process can result in a truncated or partial artifact files being created by the file storage backend. Subsequent sync(s) will silently create an Artifact in the DB that references the broken file. The only way to fix the situation is to delete the file in /var/lib/pulp/artifact and the Artifact in the DB.

This can be most easily reproduced with large files and a slow filesystem.

The regression was introduced: https://github.com/pulp/pulp/pull/3178. The problem is in django FileSystemStorage.

History

#1 Updated by jortel@redhat.com over 2 years ago

  • Description updated (diff)

This is a regression knowingly introduced: https://github.com/pulp/pulp/pull/3178

#2 Updated by bmbouter over 2 years ago

Is there an upstream bug in Django on this? It seems the defect is in their code.

#3 Updated by CodeHeeler over 2 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#4 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF