Project

Profile

Help

Issue #3876

Can't recursively copy RPM between repos

Added by Ichimonji10 over 1 year ago. Updated 7 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
2.18.0
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 40

Description

Let's say one tries to recursively copy an RPM from one repository to another with this command:

pulp-admin rpm repo copy rpm \
  --from-repo-id 73a3e0b0-2265-4ae3-bd1c-7a1d32fde068 \
  --to-repo-id 501c7a1a-9b90-4a71-b1d0-0b889390cd27 \
  --str-eq name=walrus \
  --str-eq version=0.71 \
  --recursive

It will fail with a message like this:

This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Failed

str2dir() got an unexpected keyword argument 'create'

Here's what the logs show on the target host:

Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976) Exception from importer [yum_importer] while importing units into repository [bd200d7f-2c78-425a-bdc8-d77e9612f1fc]
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976) Traceback (most recent call last):
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp/server/managers/repo/unit_association.py", line 273, in associate_from_repo
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     units=transfer_units)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/importer.py", line 58, in import_units
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     return associate.associate(source_repo, dest_repo, import_conduit, config, units)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/associate.py", line 55, in associate
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     solver.load()
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/pulp_solv.py", line 360, in load
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     self.mapping.add_repo_units(self._repo_units(repo_name), repo_name)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/pulp_solv.py", line 259, in add_repo_units
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     solvable = factory(repo, unit)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/pulp_solv.py", line 218, in <lambda>
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     return lambda solv_repo, unit: unit_solvable_converter(solv_repo, unit, *attribute_factories)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/pulp_solv.py", line 213, in unit_solvable_converter
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     attribute_factory(solvable, unit)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/pulp_solv.py", line 190, in rpm_filelist_conversion
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976)     dirname_id = repodata.str2dir(dirname, create=True)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.managers.repo.unit_association:ERROR: [99d0db51] (1860-42976) TypeError: str2dir() got an unexpected keyword argument 'create'
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: pulp.server.async.tasks:INFO: [99d0db51] Task failed : [99d0db51-c2f2-42b6-b577-2a50fc4d2f37]
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976) Task pulp.server.managers.repo.unit_association.associate_from_repo[99d0db51-c2f2-42b6-b577-2a50fc4d2f37] raised unexpected: TypeError("str2dir() got an unexpected keyword argument 'create'",)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976) Traceback (most recent call last):
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 367, in trace_task
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)     R = retval = fun(*args, **kwargs)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 529, in __call__
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)     return super(Task, self).__call__(*args, **kwargs)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 107, in __call__
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)     return super(PulpTask, self).__call__(*args, **kwargs)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 622, in __protected_call__
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)     return self.run(*args, **kwargs)
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)   File "/usr/lib/python2.7/site-packages/pulp/server/managers/repo/unit_association.py", line 291, in associate_from_repo
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976)     raise (e, None, sys.exc_info()[2])
Jul 20 13:06:14 rhel-7-pulp-2-17-nightly pulp[1860]: celery.app.trace:ERROR: [99d0db51] (1860-42976) TypeError: str2dir() got an unexpected keyword argument 'create'

This occurs on Pulp 2 nightly (to-be 2.17). Here's the RPMs used on the test VM:

[root@rhel-7-pulp-2-17-nightly ~]# rpm -qa | grep pulp | sort
pulp-admin-client-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
pulp-deb-admin-extensions-1.8.0-0.1.alpha.201807190515git4df9825.el7.noarch
pulp-deb-plugins-1.8.0-0.1.alpha.201807190515git4df9825.el7.noarch
pulp-docker-admin-extensions-3.2.0-0.1.alpha.201807190502git4356228.el7.noarch
pulp-docker-plugins-3.2.0-0.1.alpha.201807190502git4356228.el7.noarch
pulp-ostree-admin-extensions-1.4.0-0.1.alpha.201807190504git2c2d534.el7.noarch
pulp-ostree-plugins-1.4.0-0.1.alpha.201807190504git2c2d534.el7.noarch
pulp-puppet-admin-extensions-2.17.0-0.1.alpha.201807190505git44a02f8.el7.noarch
pulp-puppet-plugins-2.17.0-0.1.alpha.201807190505git44a02f8.el7.noarch
pulp-puppet-tools-2.17.0-0.1.alpha.201807190505git44a02f8.el7.noarch
pulp-python-admin-extensions-2.1.0-0.1.alpha.201807190501gitfabd48c.el7.noarch
pulp-python-plugins-2.1.0-0.1.alpha.201807190501gitfabd48c.el7.noarch
pulp-rpm-admin-extensions-2.17.0-0.1.alpha.201807190507git17a2f5d.el7.noarch
pulp-rpm-plugins-2.17.0-0.1.alpha.201807190507git17a2f5d.el7.noarch
pulp-selinux-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
pulp-server-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
python-isodate-0.5.0-4.pulp.el7.noarch
python-pulp-bindings-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
python-pulp-client-lib-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
python-pulp-common-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
python-pulp-deb-common-1.8.0-0.1.alpha.201807190515git4df9825.el7.noarch
python-pulp-docker-common-3.2.0-0.1.alpha.201807190502git4356228.el7.noarch
python-pulp-oid_validation-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
python-pulp-ostree-common-1.4.0-0.1.alpha.201807190504git2c2d534.el7.noarch
python-pulp-puppet-common-2.17.0-0.1.alpha.201807190505git44a02f8.el7.noarch
python-pulp-python-common-2.1.0-0.1.alpha.201807190501gitfabd48c.el7.noarch
python-pulp-repoauth-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch
python-pulp-rpm-common-2.17.0-0.1.alpha.201807190507git17a2f5d.el7.noarch
python-pulp-streamer-2.17.0-0.1.alpha.201807190510git37c3b3b.el7.noarch

To reproduce, run an existing test: python -m unittest pulp_2_tests.tests.rpm.cli.test_copy_units.UpdateRpmTestCase.

Associated revisions

Revision 49cc1909 View on GitHub
Added by daviddavis over 1 year ago

Remove create kwarg since by default it's true

We discovered an issue where on some versions of python2-solv, there was
no create kwarg for str2dir. So we're removing it from this call since
by default it's True anyway.

Note that this is not really a fix for #3876

https://pulp.plan.io/issues/3876
ref #3876

History

#1 Updated by Ichimonji10 over 1 year ago

This is a regression.

#2 Updated by daviddavis over 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 40

#3 Updated by amacdona@redhat.com over 1 year ago

  • Sprint/Milestone set to 2.17.0

#4 Updated by jortel@redhat.com over 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com

#5 Updated by jortel@redhat.com over 1 year ago

This worked for me using the required version of libsolv:
  • python2-solv-0.6.34-3.fc27.x86_64
  • libsolv-0.6.34-3.fc27.x86_64

I stepped through with the debugger and verified the line of code in the trace was being called without exception.

What version of python2-solv is installed on this box?

#6 Updated by Ichimonji10 over 1 year ago

This error only occurs on RHEL 7. It doesn't occur on Fedora 27. I just re-tested with freshly provisioned VMs. Here's the relevant RPMs on RHEL 7:

[root@rhel-7-pulp-2-17-nightly ~]# rpm -qa | grep solv | sort
libsolv-0.6.34-3.el7.x86_64
python2-solv-0.6.34-3.el7.x86_64
[root@fedora-27-pulp-2-17-nightly ~]# rpm -qa | grep pulp | sort
pulp-admin-client-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
pulp-deb-admin-extensions-1.8.0-0.1.alpha.201807310516git4df9825.fc27.noarch
pulp-deb-plugins-1.8.0-0.1.alpha.201807310516git4df9825.fc27.noarch
pulp-docker-admin-extensions-3.2.0-0.1.alpha.201807310503git4356228.fc27.noarch
pulp-docker-plugins-3.2.0-0.1.alpha.201807310503git4356228.fc27.noarch
pulp-ostree-admin-extensions-1.4.0-0.1.alpha.201807310504git2c2d534.fc27.noarch
pulp-ostree-plugins-1.4.0-0.1.alpha.201807310504git2c2d534.fc27.noarch
pulp-puppet-admin-extensions-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
pulp-puppet-plugins-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
pulp-puppet-tools-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
pulp-python-admin-extensions-2.1.0-0.1.alpha.201807310501git5e2aa35.fc27.noarch
pulp-python-plugins-2.1.0-0.1.alpha.201807310501git5e2aa35.fc27.noarch
pulp-rpm-admin-extensions-2.17.0-0.1.alpha.201807310508giteaff2ca.fc27.noarch
pulp-rpm-plugins-2.17.0-0.1.alpha.201807310508giteaff2ca.fc27.noarch
pulp-selinux-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
pulp-server-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-bindings-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-client-lib-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-common-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-deb-common-1.8.0-0.1.alpha.201807310516git4df9825.fc27.noarch
python-pulp-docker-common-3.2.0-0.1.alpha.201807310503git4356228.fc27.noarch
python-pulp-oid_validation-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-ostree-common-1.4.0-0.1.alpha.201807310504git2c2d534.fc27.noarch
python-pulp-puppet-common-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
python-pulp-python-common-2.1.0-0.1.alpha.201807310501git5e2aa35.fc27.noarch
python-pulp-repoauth-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-rpm-common-2.17.0-0.1.alpha.201807310508giteaff2ca.fc27.noarch
python-pulp-streamer-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch

And on F27 (again, the test passes on F27):

[root@fedora-27-pulp-2-17-nightly ~]# rpm -qa | grep solv | sort
libsolv-0.6.34-3.fc27.x86_64
python2-solv-0.6.34-3.fc27.x86_64
[root@fedora-27-pulp-2-17-nightly ~]# rpm -qa | grep pulp | sort
pulp-admin-client-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
pulp-deb-admin-extensions-1.8.0-0.1.alpha.201807310516git4df9825.fc27.noarch
pulp-deb-plugins-1.8.0-0.1.alpha.201807310516git4df9825.fc27.noarch
pulp-docker-admin-extensions-3.2.0-0.1.alpha.201807310503git4356228.fc27.noarch
pulp-docker-plugins-3.2.0-0.1.alpha.201807310503git4356228.fc27.noarch
pulp-ostree-admin-extensions-1.4.0-0.1.alpha.201807310504git2c2d534.fc27.noarch
pulp-ostree-plugins-1.4.0-0.1.alpha.201807310504git2c2d534.fc27.noarch
pulp-puppet-admin-extensions-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
pulp-puppet-plugins-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
pulp-puppet-tools-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
pulp-python-admin-extensions-2.1.0-0.1.alpha.201807310501git5e2aa35.fc27.noarch
pulp-python-plugins-2.1.0-0.1.alpha.201807310501git5e2aa35.fc27.noarch
pulp-rpm-admin-extensions-2.17.0-0.1.alpha.201807310508giteaff2ca.fc27.noarch
pulp-rpm-plugins-2.17.0-0.1.alpha.201807310508giteaff2ca.fc27.noarch
pulp-selinux-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
pulp-server-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-bindings-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-client-lib-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-common-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-deb-common-1.8.0-0.1.alpha.201807310516git4df9825.fc27.noarch
python-pulp-docker-common-3.2.0-0.1.alpha.201807310503git4356228.fc27.noarch
python-pulp-oid_validation-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-ostree-common-1.4.0-0.1.alpha.201807310504git2c2d534.fc27.noarch
python-pulp-puppet-common-2.17.0-0.1.alpha.201807310506git44a02f8.fc27.noarch
python-pulp-python-common-2.1.0-0.1.alpha.201807310501git5e2aa35.fc27.noarch
python-pulp-repoauth-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch
python-pulp-rpm-common-2.17.0-0.1.alpha.201807310508giteaff2ca.fc27.noarch
python-pulp-streamer-2.17.0-0.1.alpha.201807310510git0697ade.fc27.noarch

#7 Updated by ipanova@redhat.com over 1 year ago

thanks @ichimonji10 for re-testing. We are carrying the dependency for rhel7 so we should figure out what's wrong.

#8 Updated by daviddavis over 1 year ago

  • Assignee changed from jortel@redhat.com to daviddavis

#9 Updated by daviddavis over 1 year ago

This is not really a fix for this issue but I am dropping use of the create kwarg:

https://github.com/pulp/pulp_rpm/pull/1150

#10 Updated by pcreech over 1 year ago

So far, the srpms are identical (with the exclusion of the specfile modifications we made)


 diff -r el7/ fc27/
Only in el7/: libsolv-0.6.34-3.el7.src.rpm
Only in fc27/: libsolv-0.6.34-3.fc27.src.rpm
diff -r el7/libsolv.spec fc27/libsolv.spec
200,201c200,203
< %post -p /sbin/ldconfig
< %postun -p /sbin/ldconfig
---
> %check
> %ninja_test -C "%{_vpath_builddir}" 
> 
> %ldconfig_scriptlets

#11 Updated by pcreech over 1 year ago

Looking into the generated bindings in python2-solv, it became apparent that a significant amount of the method signatures were different.

Upon closer inspection, the version of swig was an entire major version different between el7 and fedora. Swig 2 on el7, and Swig 3 on fedora.

swig is strictly BuildRequires by libsolv, and is only used in generating these bindings. I've done a build of swig 3 in koji against rhel7, with only removing python3 dependencies.

With the minimal needs of swig, my next step is to go ahead and build swig in the rhel7 tag in koji, and do a scratch rebuild of libsolv and compare the bindings again.

#12 Updated by pcreech over 1 year ago

swig 3 has been rebuilt into pulp-nightly-rhel7 and libsolv has been rebuilt against it.

Here is the new diff for bindings between el7 and fc27:

diff -r el7/usr/lib64/python2.7/site-packages/solv.py fc27/usr/lib64/python2.7/site-packages/solv.py
1328a1329
>     SUSETAGS_RECORD_SHARES = _solv.Repo_SUSETAGS_RECORD_SHARES
1368a1370,1396
> 
>     def add_debdb(self, flags=0):
>         return _solv.Repo_add_debdb(self, flags)
> 
>     def add_debpackages(self, fp, flags=0):
>         return _solv.Repo_add_debpackages(self, fp, flags)
> 
>     def add_deb(self, name, flags=0):
>         return _solv.Repo_add_deb(self, name, flags)
> 
>     def add_susetags(self, fp, defvendor, language, flags=0):
>         return _solv.Repo_add_susetags(self, fp, defvendor, language, flags)
> 
>     def add_content(self, fp, flags=0):
>         return _solv.Repo_add_content(self, fp, flags)
> 
>     def add_products(self, proddir, flags=0):
>         return _solv.Repo_add_products(self, proddir, flags)
> 
>     def add_arch_repo(self, fp, flags=0):
>         return _solv.Repo_add_arch_repo(self, fp, flags)
> 
>     def add_arch_local(self, dir, flags=0):
>         return _solv.Repo_add_arch_local(self, dir, flags)
> 
>     def add_arch_pkg(self, name, flags=0):
>         return _solv.Repo_add_arch_pkg(self, name, flags)

The libsolv build is now under automated testing. Manual testing would also be appreciated

#13 Updated by Ichimonji10 over 1 year ago

Tested by applying the following diff to Pulp 2 Tests (this diff will be unnecessary once this issue changes to a state such as MODIFIED or ON_QA):

diff --git a/pulp_2_tests/tests/rpm/utils.py b/pulp_2_tests/tests/rpm/utils.py
index be7d10a..206ce1b 100644
--- a/pulp_2_tests/tests/rpm/utils.py
+++ b/pulp_2_tests/tests/rpm/utils.py
@@ -121,8 +121,7 @@ def check_issue_3876(cfg):

     .. _Pulp #3876: https://pulp.plan.io/issues/3876
     """ 
-    return (cfg.pulp_version >= Version('2.17') and
-            not selectors.bug_is_fixed(3876, cfg.pulp_version))
+    return False

 def os_is_f26(cfg, pulp_host=None):

...then installing Pulp 2.17 nightly on Fedora 27 and RHEL 7, and running the following command: python -m unittest --failfast --verbose pulp_2_tests.tests.rpm.cli.test_copy_units. All test passed. Here's the RPMs on Fedora 27:

[root@fedora-27-pulp-2-17-nightly ~]# rpm -qa | grep -i 'solv\|pulp' | sort
libsolv-0.6.34-3.fc27.x86_64
pulp-admin-client-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
pulp-deb-admin-extensions-1.8.0-0.1.alpha.201808010517git4df9825.fc27.noarch
pulp-deb-plugins-1.8.0-0.1.alpha.201808010517git4df9825.fc27.noarch
pulp-docker-admin-extensions-3.2.0-0.1.alpha.201808010504git4356228.fc27.noarch
pulp-docker-plugins-3.2.0-0.1.alpha.201808010504git4356228.fc27.noarch
pulp-ostree-admin-extensions-1.4.0-0.1.alpha.201808010506git2c2d534.fc27.noarch
pulp-ostree-plugins-1.4.0-0.1.alpha.201808010506git2c2d534.fc27.noarch
pulp-puppet-admin-extensions-2.17.0-0.1.alpha.201808010507git44a02f8.fc27.noarch
pulp-puppet-plugins-2.17.0-0.1.alpha.201808010507git44a02f8.fc27.noarch
pulp-puppet-tools-2.17.0-0.1.alpha.201808010507git44a02f8.fc27.noarch
pulp-python-admin-extensions-2.1.0-0.1.alpha.201808010503git5e2aa35.fc27.noarch
pulp-python-plugins-2.1.0-0.1.alpha.201808010503git5e2aa35.fc27.noarch
pulp-rpm-admin-extensions-2.17.0-0.1.alpha.201808010509git421caf4.fc27.noarch
pulp-rpm-plugins-2.17.0-0.1.alpha.201808010509git421caf4.fc27.noarch
pulp-selinux-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
pulp-server-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
python2-solv-0.6.34-3.fc27.x86_64
python-pulp-bindings-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
python-pulp-client-lib-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
python-pulp-common-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
python-pulp-deb-common-1.8.0-0.1.alpha.201808010517git4df9825.fc27.noarch
python-pulp-docker-common-3.2.0-0.1.alpha.201808010504git4356228.fc27.noarch
python-pulp-oid_validation-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
python-pulp-ostree-common-1.4.0-0.1.alpha.201808010506git2c2d534.fc27.noarch
python-pulp-puppet-common-2.17.0-0.1.alpha.201808010507git44a02f8.fc27.noarch
python-pulp-python-common-2.1.0-0.1.alpha.201808010503git5e2aa35.fc27.noarch
python-pulp-repoauth-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch
python-pulp-rpm-common-2.17.0-0.1.alpha.201808010509git421caf4.fc27.noarch
python-pulp-streamer-2.17.0-0.1.alpha.201808010512git0697ade.fc27.noarch

Here's the RPMs on RHEL 7:

[root@rhel-7-pulp-2-17-nightly ~]# rpm -qa | grep -i 'solv\|pulp' | sort
libsolv-0.6.34-4.el7.x86_64
pulp-admin-client-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
pulp-deb-admin-extensions-1.8.0-0.1.alpha.201808010517git4df9825.el7.noarch
pulp-deb-plugins-1.8.0-0.1.alpha.201808010517git4df9825.el7.noarch
pulp-docker-admin-extensions-3.2.0-0.1.alpha.201808010504git4356228.el7.noarch
pulp-docker-plugins-3.2.0-0.1.alpha.201808010504git4356228.el7.noarch
pulp-ostree-admin-extensions-1.4.0-0.1.alpha.201808010506git2c2d534.el7.noarch
pulp-ostree-plugins-1.4.0-0.1.alpha.201808010506git2c2d534.el7.noarch
pulp-puppet-admin-extensions-2.17.0-0.1.alpha.201808010507git44a02f8.el7.noarch
pulp-puppet-plugins-2.17.0-0.1.alpha.201808010507git44a02f8.el7.noarch
pulp-puppet-tools-2.17.0-0.1.alpha.201808010507git44a02f8.el7.noarch
pulp-python-admin-extensions-2.1.0-0.1.alpha.201808010503git5e2aa35.el7.noarch
pulp-python-plugins-2.1.0-0.1.alpha.201808010503git5e2aa35.el7.noarch
pulp-rpm-admin-extensions-2.17.0-0.1.alpha.201808010509git421caf4.el7.noarch
pulp-rpm-plugins-2.17.0-0.1.alpha.201808010509git421caf4.el7.noarch
pulp-selinux-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
pulp-server-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
python2-solv-0.6.34-4.el7.x86_64
python-isodate-0.5.0-4.pulp.el7.noarch
python-pulp-bindings-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
python-pulp-client-lib-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
python-pulp-common-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
python-pulp-deb-common-1.8.0-0.1.alpha.201808010517git4df9825.el7.noarch
python-pulp-docker-common-3.2.0-0.1.alpha.201808010504git4356228.el7.noarch
python-pulp-oid_validation-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
python-pulp-ostree-common-1.4.0-0.1.alpha.201808010506git2c2d534.el7.noarch
python-pulp-puppet-common-2.17.0-0.1.alpha.201808010507git44a02f8.el7.noarch
python-pulp-python-common-2.1.0-0.1.alpha.201808010503git5e2aa35.el7.noarch
python-pulp-repoauth-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch
python-pulp-rpm-common-2.17.0-0.1.alpha.201808010509git421caf4.el7.noarch
python-pulp-streamer-2.17.0-0.1.alpha.201808010512git0697ade.el7.noarch

A quick peek into journalctl output doesn't show anything worrying.

#14 Updated by ipanova@redhat.com over 1 year ago

  • Tracker changed from Issue to Task
  • Status changed from ASSIGNED to CLOSED - COMPLETE
  • % Done set to 0

#15 Updated by Ichimonji10 over 1 year ago

It appears that RPMs weren't built last night. This explains why this test case still fails.

#16 Updated by ipanova@redhat.com over 1 year ago

  • Platform Release set to 2.17.0

#17 Updated by ipanova@redhat.com over 1 year ago

  • Platform Release changed from 2.17.0 to master

#18 Updated by ipanova@redhat.com over 1 year ago

  • Platform Release deleted (master)

#19 Updated by ipanova@redhat.com over 1 year ago

  • Platform Release set to 2.17.0

#20 Updated by pcreech about 1 year ago

  • Tracker changed from Task to Issue
  • Priority changed from Normal to High
  • Severity set to 2. Medium
  • Platform Release deleted (2.17.0)
  • Triaged set to No

Release engineering is having to back out it's fix for this issue, and therefore it will occur again.

I've re-opened the PR here https://github.com/pulp/pulp_rpm/pull/1150

We will need to resolve for pulp 2.17.x, should block next pulp 2.17.x as this will now become a regression until the code is fixed.

#21 Updated by daviddavis 12 months ago

  • Tracker changed from Issue to Task
  • Status changed from CLOSED - COMPLETE to MODIFIED
  • Sprint/Milestone changed from 2.17.0 to 2.18.0
  • % Done set to 0

#22 Updated by daviddavis 12 months ago

  • Tracker changed from Task to Issue
  • Severity set to 2. Medium
  • Triaged set to No

#23 Updated by ttereshc 12 months ago

  • Platform Release set to 2.18.0

#24 Updated by ttereshc 12 months ago

  • Status changed from MODIFIED to ON_QA

#25 Updated by ttereshc 11 months ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

#26 Updated by bmbouter 7 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF