Project

Profile

Help

Issue #3820

Can't sync Google RPM repository

Added by dkliban@redhat.com over 3 years ago. Updated over 2 years ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 39
Quarter:

Description

pulp-admin rpm repo create --feed https://packages.cloud.google.com/yum/repos/google-cloud-compute-el7-x86_64 --repo-id google
pulp-admin rpm repo sync run --repo-id google

The sync finishes with an error. The problem seems to be the updateinfo file. The "issued" element of the errata is different from errata published by RedHat.

Google:

    <issued>
      <date>2017-08-31 00:00:00</date>

RedHat:

<issued date='2017-08-31 00:00:00'>
</issued>

History

#1 Updated by dkliban@redhat.com over 3 years ago

  • Sprint set to Sprint 39

#2 Updated by bmbouter over 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter

#3 Updated by CodeHeeler over 3 years ago

  • Triaged changed from No to Yes

#4 Updated by bmbouter over 3 years ago

I was able to reproduce the issue exactly as written. It gives traceback:

Traceback (most recent call last):
  File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/sync.py", line 283, in run
    self.get_errata(metadata_files)
  File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/sync.py", line 867, in get_errata
    updateinfo.process_package_element, additive_type=True)
  File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/sync.py", line 949, in save_fileless_units
    for model in package_info_generator:
  File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/repomd/packages.py", line 64, in package_list_generator
    package_info = process_func(element)
  File "/home/vagrant/devel/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/repomd/updateinfo.py", line 81, in process_package_element
    package_info['issued'] = issued_element.attrib['date']
KeyError: 'date'

#5 Updated by bmbouter over 3 years ago

  • Status changed from ASSIGNED to POST

#6 Updated by bmbouter over 3 years ago

  • Status changed from POST to CLOSED - WORKSFORME

This is extremely strange. I now cannot reproduce the issue. Also in debugging the code from the existing pulp/pulp_rpm:2-master branch I see it finding the date correctly for the reproducer repo. I believe something changed with the remote metadata.

I'm going to close the PR and also this issue as WORKSFORME.

#7 Updated by dkliban@redhat.com over 3 years ago

I could not reproduce it now either. I was able to before.

#8 Updated by daviddavis over 3 years ago

In the remote xml I see <issued date="2017-08-31 00:00:00"></issued>. I am guessing Google fixed the updateinfo.xml.

+1 to WORKSFORME

#9 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF