Project

Profile

Help

Story #3779

As a user, I want to publish/export Text-Only errata

Added by ttereshc over 3 years ago. Updated almost 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Pulp filters out errata without packages during publish.
So between remote source and publish result there can be difference in the number of errata.
These errata will never be shown as applicable, it's informative in case someone reads it.

Example of text-only errata:
- when container image is released
- when packages getting deprecated in that repo are announced

These errata don't have any RPM packages associated with them.

Current behaviour is not a bug and such errata are filtered out on purpose.
When implementing this RFE, make sure to distinguish between an erratum which has never had packages in its pkglist and an erratum which doesn't have packages because they are not present in a repo.

History

#1 Updated by ttereshc over 3 years ago

  • Tracker changed from Issue to Story
  • Subject changed from Text-Only errata are not being published or exported to As a user, I want to publish/export Text-Only errata
  • Description updated (diff)
  • % Done set to 0

#2 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#3 Updated by ttereshc almost 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

This RFE won't be implemented in Pulp2.
Pulp 3 supports text-only errata natively.

Please register to edit this issue

Also available in: Atom PDF