Project

Profile

Help

Issue #374

pulp-manage-db deprecation warning on rhel6

Added by pthomas@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Low
Assignee:
-
Category:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Master
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
I see the following error on running pulp-manage-db on a el6

[root@pulp-node2 ~]# pulp-manage-db
Beginning database migrations.
/usr/lib/python2.6/site-packages/pulp/server/db/connection.py:103: DeprecationWarning: The safe parameter is deprecated. Please use write concern options instead.
return method(*args, **kwargs)
Applying pulp.server.db.migrations version 1

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1012989 +

History

#1 Updated by cduryee over 5 years ago

This is still outstanding as of pulp 2.4.3

+ This comment was cloned from Bugzilla #1012989 comment 1 +

#2 Updated by jcline@redhat.com over 4 years ago

  • Status changed from NEW to 5
  • Severity set to 1. Low
  • Platform Release set to 2.8.0

Because Randy said 2.8.0 (also because we now use pymongo 3 and this option is gone)

#3 Updated by dkliban@redhat.com over 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#4 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF