Project

Profile

Help

Issue #365

closed

wrong value in repoid when uninstalling using pulp-admin

Added by pthomas@redhat.com almost 8 years ago. Updated over 3 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.2 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

If you use pulp-admin to unistall, the repoid in the report has the value as installed

Version-Release number of selected component (if applicable):

[root@hp-dl380pgen8-02-vm-16 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.25.beta.fc19.noarch
[root@hp-dl380pgen8-02-vm-16 ~]#

How reproducible:

Steps to Reproduce:
[root@hp-dl380pgen8-02-vm-16 ~]# pulp-admin rpm consumer package uninstall run --consumer-id consumer1 --name zsh
Uninstall task created with id [ 97d1c884-6e74-4c88-a0ce-cb7291edb9d0 ]

This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata [ OK ]
Downloading Packages [ OK ]
Running Test Transaction [ OK ]
Running Transaction [ OK ]

Uninstall Completed

--------------------------------------------------------------------
Uninstalled
--------------------------------------------------------------------

Name: zsh
Version: 4.3.10
Arch: x86_64
Repoid: installed

[root@hp-dl380pgen8-02-vm-16 ~]#

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #997411 +

Also available in: Atom PDF