Project

Profile

Help

Issue #3658

problem with install and setup

Added by dtkloc over 3 years ago. Updated over 2 years ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I am probably doing something wrong and need some assistance and could not find somewhere else to reach out for help. I am trying to mirror the apt repo for Ubuntu and runing into some issues,
Here are the commands i run:

pulp-admin deb repo create --repo-id 'xenial-amd64' --feed 'http://mirror.umd.edu/ubuntu' --releases 'xenial' --components 'main' --architectures 'amd64'
pulp-admin deb repo sync run --repo-id 'xenial-amd64'

Both ot theses work fine and i can browse the repo, However when i attempt to point a client to the pulp server I get errors that the the xenial Release does not have a release file. I am i missing some instructions? How do I get around this?

this is contents of the pulp website I have built

Pulp Repository Content

Parent Directory
main/
Release

History

#1 Updated by mdellweg over 3 years ago

Can you be a bit more specific about the "point a client to the pulp server" part? The exact line in sources.list might be helpful.
Also the output of `pulp-admin deb repo list --details --repo-id xenial-amd64` could help here.

#2 Updated by quba42 almost 3 years ago

If no further details are forthcoming, then this issue should probably be closed?

#3 Updated by mdellweg almost 3 years ago

  • Status changed from NEW to CLOSED - WORKSFORME

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF