Project

Profile

Help

Issue #365

wrong value in repoid when uninstalling using pulp-admin

Added by pthomas@redhat.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.2 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

If you use pulp-admin to unistall, the repoid in the report has the value as installed

Version-Release number of selected component (if applicable):

[root@hp-dl380pgen8-02-vm-16 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.25.beta.fc19.noarch
[root@hp-dl380pgen8-02-vm-16 ~]#

How reproducible:

Steps to Reproduce:
[root@hp-dl380pgen8-02-vm-16 ~]# pulp-admin rpm consumer package uninstall run --consumer-id consumer1 --name zsh
Uninstall task created with id [ 97d1c884-6e74-4c88-a0ce-cb7291edb9d0 ]

This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata [ OK ]
Downloading Packages [ OK ]
Running Test Transaction [ OK ]
Running Transaction [ OK ]

Uninstall Completed

--------------------------------------------------------------------
Uninstalled
--------------------------------------------------------------------

Name: zsh
Version: 4.3.10
Arch: x86_64
Repoid: installed

[root@hp-dl380pgen8-02-vm-16 ~]#

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #997411 +

History

#1 Updated by skarmark@redhat.com over 6 years ago

Remove repo id from the report.

+ This comment was cloned from Bugzilla #997411 comment 1 +

#2 Updated by mhrivnak over 6 years ago

***** Bug 843848 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #997411 comment 2 +

#3 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#4 Updated by bmbouter over 2 years ago

  • Severity set to 1. Low

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF