Project

Profile

Help

Maintenance. Planio will be undergoing a scheduled maintenance this weekend. Between Saturday, July 24 at 9:00 UTC and Sunday, July 25, 22:00 UTC your account might observe occasional downtimes which may last up to several minutes in some cases.

Issue #355

Need error handling and message for repo sync with a bad feed

Added by pthomas@redhat.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.2 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

Repo sync fails with no error message when syncing repos with a bad feed url.

Version-Release number of selected component (if applicable):

[root@hp-dl360g6-01 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.2.beta.fc18.noarch

How reproducible:

Steps to Reproduce:
1.create a repo with bad feed
2.Sync the repo
3.

Actual results:
[root@hp-dl360g6-01 ~]# pulp-admin iso repo create --repo-id "ABC" --feed test
Successfully created repository [ABC]

[root@hp-dl360g6-01 ~]# pulp-admin rpm repo create --repo-id "ABCD" --feed test
Successfully created repository [ABCD]

[root@hp-dl360g6-01 ~]# pulp-admin rpm repo sync run --repo-id "ABCD"
--------------------------------------------------------------------
Synchronizing Repository [ABCD]
--------------------------------------------------------------------

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[-]
[root@hp-dl360g6-01 ~]# pulp-admin iso repo sync run --repo-id "ABCD"
--------------------------------------------------------------------
Synchronizing Repository [ABCD]
--------------------------------------------------------------------

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #973172 +

History

#1 Updated by mhrivnak over 6 years ago

It looks like this has been fixed for both iso and rpm syncs.

+ This comment was cloned from Bugzilla #973172 comment 1 +

#2 Updated by jortel@redhat.com over 6 years ago

build: 2.3.0-0.10.alpha

+ This comment was cloned from Bugzilla #973172 comment 2 +

#3 Updated by pthomas@redhat.com over 6 years ago

failing, iso repo sync with bad feed's output should be consistent with rpm

[root@pulp-v2-server ~]# pulp-admin iso repo create --repo-id "ABC" --feed test
Successfully created repository [ABC]

[root@pulp-v2-server ~]# pulp-admin rpm repo create --repo-id "ABCD" --feed test
Successfully created repository [ABCD]

[root@pulp-v2-server ~]# pulp-admin rpm repo sync run --repo-id "ABCD"
--------------------------------------------------------------------
Synchronizing Repository [ABCD]
--------------------------------------------------------------------

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[-]
... failed

Unsupported scheme:

[root@pulp-v2-server ~]# pulp-admin iso repo sync run --repo-id "ABC"
--------------------------------------------------------------------
Synchronizing Repository [ABC]
--------------------------------------------------------------------

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest failed:

{u'response_code': 0, u'error_message': u"Couldn't resolve host 'test'",
u'error_code': 6}

[root@pulp-v2-server ~]#

+ This comment was cloned from Bugzilla #973172 comment 3 +

#4 Updated by cduryee over 6 years ago

These still have different outputs as of pulp 2.4.3

$ pulp-admin rpm repo sync run --repo-id "ABCD"
--------------------------------------------------------------------
Synchronizing Repository [ABCD]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[-]
... failed

Unsupported scheme:

Task Failed

Importer indicated a failed response

$ pulp-admin iso repo sync run --repo-id "ABC"
--------------------------------------------------------------------
Synchronizing Repository [ABC]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Downloading the Pulp Manifest failed:

{}

Task Failed

Importer indicated a failed response

+ This comment was cloned from Bugzilla #973172 comment 4 +

#5 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX
  • Severity set to 2. Medium

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#6 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF