Project

Profile

Help

Issue #354

closed

ISO files become zero-byte when syncing from local published ISO repo

Added by pthomas@redhat.com over 7 years ago. Updated about 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

iso repo sync failing with local feed

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. I created and synced an iso repo

[root@hp-dl360g6-01 ~]# ls l /var/lib/pulp/published/https/isos/iso.repo/
total 16
-rw-r--r-
. 1 apache apache 251 Jun 10 13:07 PULP_MANIFEST
lrwxrwxrwx. 1 apache apache 118 Jun 10 13:07 test2.iso -> /var/lib/pulp/content/iso/test2.iso/042c259d546331588e1dff83a46f62a27fb7cf3de4050924470d99fd8d2a046f/4358144/test2.iso
lrwxrwxrwx. 1 apache apache 118 Jun 10 13:07 test3.iso -> /var/lib/pulp/content/iso/test3.iso/f56e08898287e60b3169392351e9296bbe28417db1f8e34e8058d124be89b93a/3244032/test3.iso
lrwxrwxrwx. 1 apache apache 116 Jun 10 13:07 test.iso -> /var/lib/pulp/content/iso/test.iso/582f1729b0c15eacbb7d02a553c0a96a39f817135c15ac4190aef96e45c4b65d/3145728/test.iso

2. Create a second repo with local feed to the above repo locations

[root@hp-dl360g6-01 ~]# pulp-admin iso repo create --repo-id local-iso --feed file:////var/lib/pulp/published/https/isos/iso.repo/
Successfully created repository [local-iso]

3. Sync that repo
[root@hp-dl360g6-01 ~]# pulp-admin iso repo sync run --repo-id local-iso
--------------------------------------------------------------------
Synchronizing Repository [local-iso]
--------------------------------------------------------------------

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest failed:

None

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #972880 +

Actions #1

Updated by cduryee over 7 years ago

Tested with Pulp 2.5.0-0.17.rc

I was able to sync locally from a repo under /tmp with success after disabling selinux. However, when I tried to sync again from the published directory (step #2 in original report), my iso files under /var/lib/pulp/content became zero-byte.

+ This comment was cloned from Bugzilla #972880 comment 1 +

Actions #2

Updated by cduryee over 7 years ago

I am not sure about the severity of this bz. Removing triaged tag so this gets re-triaged.

+ This comment was cloned from Bugzilla #972880 comment 2 +

Actions #4

Updated by cduryee over 7 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #972880 comment 4 +

Actions #5

Updated by pthomas@redhat.com over 7 years ago

[root@gizmo ~]# rpm -qa pulp-server
pulp-server-2.6.0-0.5.beta.el6.noarch
[root@gizmo ~]#

[root@gizmo ~]# pulp-admin iso repo create --repo-id local-iso --feed file:////var/lib/pulp/published/https/isos/iso/
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

Successfully created repository [local-iso]

[root@gizmo ~]#
[root@gizmo ~]#
[root@gizmo ~]# ls l /var/lib/pulp/published/https/isos/iso/total 16
-rw-r--r-
. 1 apache apache 251 Jan 26 10:19 PULP_MANIFEST
lrwxrwxrwx. 1 apache apache 118 Jan 26 10:19 test2.iso -> /var/lib/pulp/content/iso/test2.iso/042c259d546331588e1dff83a46f62a27fb7cf3de4050924470d99fd8d2a046f/4358144/test2.iso
lrwxrwxrwx. 1 apache apache 118 Jan 26 10:19 test3.iso -> /var/lib/pulp/content/iso/test3.iso/f56e08898287e60b3169392351e9296bbe28417db1f8e34e8058d124be89b93a/3244032/test3.iso
lrwxrwxrwx. 1 apache apache 116 Jan 26 10:19 test.iso -> /var/lib/pulp/content/iso/test.iso/582f1729b0c15eacbb7d02a553c0a96a39f817135c15ac4190aef96e45c4b65d/3145728/test.iso
[root@gizmo ~]#
[root@gizmo ~]#

[root@gizmo ~]#
[root@gizmo ~]#
[root@gizmo ~]# pulp-admin iso repo sync run --repo-id local-iso
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

--------------------------------------------------------------------
Synchronizing Repository [local-iso]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

The Pulp Manifest was downloaded successfully.

There are no ISOs that need to be downloaded.

Task Succeeded

The repository was successfully published.

Task Succeeded

[root@gizmo ~]# pulp-admin iso repo list
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

--------------------------------------------------------------------
ISO Repositories
--------------------------------------------------------------------

Id: iso
Display Name: iso
Description: None
Content Unit Counts:
Iso: 3

Id: local-iso
Display Name: local-iso
Description: None
Content Unit Counts:
Iso: 3

[root@gizmo ~]#

+ This comment was cloned from Bugzilla #972880 comment 5 +

Actions #6

Updated by bmbouter over 7 years ago

  • Severity changed from Medium to 2. Medium
Actions #7

Updated by rbarlow about 7 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE
Actions #9

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF