Project

Profile

Help

Issue #3460

Pulp does not include srpm packages when generating errata

Added by bizhang over 3 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Unlike Redhat, SUSE includes srpms in published errata.

Steps to recreate:
Sync and publish some errata with srpm packages: https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP3/x86_64/update/ (some setup steps here: https://pulp.plan.io/issues/3377)

Note that published updateinfo.xml does not include any packages with arch='src'

@tanya tracked down the cause to here [0] where we only look at RPMs when creating a list of packages in a repo.

[0] https://github.com/pulp/pulp_rpm/blob/5602afc7ff2e9b77a5f1d5cb666abeb5e913bbec/plugins/pulp_rpm/plugins/distributors/yum/publish.py#L651

History

#1 Updated by dalley over 3 years ago

  • Project changed from Pulp to RPM Support

#2 Updated by bizhang over 3 years ago

  • Description updated (diff)

#3 Updated by dalley over 3 years ago

  • Triaged changed from No to Yes

#4 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF