Project

Profile

Help

Issue #3311

Folder structure not getting created / used

Added by dustball almost 3 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
RHEL 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I've recently upgraded to pulp 2.15, and was happy to finally sync debian / ubuntu.

However, while synchronization works, it does not create the "/var/www/pub/deb/"-structure named in "/etc/httpd/conf.d/pulp_deb.conf". As such, I can not serve the synchronized content.

History

#1 Updated by mihai.ibanescu@gmail.com almost 3 years ago

The bug is most likely in the spec file. Installing the Debian plugin should create /var/www/pub/deb

If you create it by hand and make it owned by apache:apache, will publishing start working?

install -d -o apache -g apache /var/www/pub/deb

#2 Updated by dustball almost 3 years ago

Nope, nothing. For reference, here are the commands and the output:

root@pulp01vp:/var/www/pub/deb # pulp-admin deb repo sync run --repo-id xenial-amd64; pulp-admin deb repo publish run --repo-id xenial-amd64
+----------------------------------------------------------------------+
                Synchronizing Repository [xenial-amd64]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Task Succeeded

Task Failed

'md5sums' file not found, can't list MD5 sums

+----------------------------------------------------------------------+
                  Publishing Repository [xenial-amd64]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Task Failed

'md5sums' file not found, can't list MD5 sums

The directories are still not getting created.

#3 Updated by mdellweg over 2 years ago

Can you make sure, https://github.com/sassoftware/python-debpkgr/pull/2 is applied to python-debpkgr.
This problem sounds a lot like it.

#4 Updated by dustball over 2 years ago

This seems to be the relevant issue. However, my "debpkg.py" isn't nearly as long (269 lines), and the relevant part is

    @classmethod
    def from_file(cls, path, **kwargs):
        """
        Allows for fields (like Filename and Size) to be added or replaced
        using keyword arguments.
        """
        debpkg = debfile.DebFile(filename=path)
        md5sums = debpkg.md5sums(encoding='utf-8')
        control = debpkg.control.debcontrol().copy()
        hashes = cls.make_hashes(path)
        control.update(kwargs)
        return cls(control, hashes, md5sums)

The whole error catching part is missing.

My version of "python2-debpkgr" is 1.0.1, built on 2017-07-12, coming from the "pulp-2.15-beta/7/x86_64" repo. I changed the repo to stable for testing purposes now, and the package seems to be the same.

Edit: I've included the exception handling and retried. It works. So the package needs to be rebuilt with error handling built in.

#5 Updated by mihai.ibanescu@gmail.com over 2 years ago

I have made debpkgr 1.0.5 available on pypi. As soon as the package gets built into the pulp repos, it should fix this issue. Apologies for not being able to debug this, I was puzzled because it worked fine for us (but we were on debpkgr 1.0.4, built internally).

#6 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - CURRENTRELEASE

It sounds like this is resolved through a packaging change. See discussion here: https://www.redhat.com/archives/pulp-list/2018-February/msg00011.html

If its not comment and we can reopen it.

#7 Updated by karlism over 1 year ago

I seem to experience similar issue on recent CentOS and Pulp version:

Feb 27 14:57:40 hostname pulp: debpkgr.debpkg:WARNING: [a5672afa] While processing /var/lib/pulp/content/units/deb/b5/0396cc8f0591271e7aa6e056b0341280711c0a85d637da34fba0b9b6608901/python-twisted-runner-dbg_17.9.0-2_all.deb: 'md5sums' file not found, can't list MD5 sums
Feb 27 14:58:01 hostname pulp: debpkgr.debpkg:WARNING: [a5672afa] While processing /var/lib/pulp/content/units/deb/4b/db303856379c5e8d4a0fe26ea1f2bdeb0a81581507f36e201822c3ce30ca1b/binutils-doc_2.30-15ubuntu1_all.deb: 'md5sums' file not found, can't list MD5 sums
Feb 27 14:58:11 hostname pulp: debpkgr.debpkg:WARNING: [a5672afa] While processing /var/lib/pulp/content/units/deb/17/06ff6c4094f5f656793abb96d084b8f225dace796d221dd9c0fe475e9a2777/libmagick++-dev_8:6.9.7.4+dfsg-16ubuntu6_all.deb: 'md5sums' file not found, can't list MD5 sums
[root@hostname tmpl]# yum list installed | grep -e pulp 
Failed to set locale, defaulting to C
libmodulemd.x86_64                 1.7.0-1.el7                    @pulp-2       
libsolv.x86_64                     0.6.34-2.pulp.el7              @pulp-2       
pulp-admin-client.noarch           2.18.1-2.el7                   @pulp-2       
pulp-deb-admin-extensions.noarch   1.8.0-1.el7                    @pulp-2       
pulp-deb-plugins.noarch            1.8.0-1.el7                    @pulp-2       
pulp-rpm-admin-extensions.noarch   2.18.1-1.el7                   @pulp-2       
pulp-rpm-plugins.noarch            2.18.1-1.el7                   @pulp-2       
pulp-selinux.noarch                2.18.1-2.el7                   @pulp-2       
pulp-server.noarch                 2.18.1-2.el7                   @pulp-2       
python-bson.x86_64                 3.2-2.el7                      @pulp-2       
python-gofer.noarch                2.12.5-1.el7                   @pulp-2       
python-gofer-qpid.noarch           2.12.5-1.el7                   @pulp-2       
python-mongoengine.noarch          0.10.5-1.el7                   @pulp-2       
python-nectar.noarch               1.5.6-1.el7                    @pulp-2       
python-pulp-bindings.noarch        2.18.1-2.el7                   @pulp-2       
python-pulp-client-lib.noarch      2.18.1-2.el7                   @pulp-2       
python-pulp-common.noarch          2.18.1-2.el7                   @pulp-2       
python-pulp-deb-common.noarch      1.8.0-1.el7                    @pulp-2       
python-pulp-oid_validation.noarch  2.18.1-2.el7                   @pulp-2       
python-pulp-repoauth.noarch        2.18.1-2.el7                   @pulp-2       
python-pulp-rpm-common.noarch      2.18.1-1.el7                   @pulp-2       
python-pymongo.x86_64              3.2-2.el7                      @pulp-2       
python-pymongo-gridfs.x86_64       3.2-2.el7                      @pulp-2       
python2-amqp.noarch                10:2.2.2-5.el7                 @pulp-2       
python2-billiard.x86_64            10:3.5.0.3-4.el7               @pulp-2       
python2-celery.noarch              10:4.0.2-7.el7                 @pulp-2       
python2-debpkgr.noarch             1.1.0-1.el7                    @pulp-2       
python2-kombu.noarch               10:4.0.2-11.el7                @pulp-2       
python2-solv.x86_64                0.6.34-2.pulp.el7              @pulp-2       
python2-vine.noarch                10:1.1.3-5.el7                 @pulp-2
[root@hostname tmp]# pulp-admin repo list --detail --repo-id=ubuntu_bionic
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

Id:                   ubuntu_bionic
Display Name:         None
Description:          None
Content Unit Counts:  
  Deb:           6391
  Deb Component: 1
  Deb Release:   1
Notes:                
Scratchpad:           
Importers:            
  Config:               
    Architectures: amd64
    Components:    main
    Feed:          http://de.archive.ubuntu.com/ubuntu
    Releases:      bionic
  Id:                   deb_importer
  Importer Type Id:     deb_importer
  Last Override Config: 
  Last Sync:            2019-02-27T14:56:31Z
  Last Updated:         2019-02-27T14:43:54Z
  Repo Id:              ubuntu_bionic
  Scratchpad:           None
Distributors:         
  Auto Publish:         True
  Config:               
    Http:         False
    Https:        True
    Relative URL: ubuntu/bionic/main
  Distributor Type Id:  deb_distributor
  Id:                   deb_distributor
  Last Override Config: 
  Last Publish:         2019-02-27T14:30:02Z
  Last Updated:         2019-02-27T14:43:55Z
  Repo Id:              ubuntu_bionic
  Scratchpad:      
[root@hostname tmp]# pulp-admin status
+----------------------------------------------------------------------+
                          Status of the server
+----------------------------------------------------------------------+

Api Version:           2
Database Connection:   
  Connected: True
Known Workers:         
  _id:            scheduler@hostname
  _ns:            workers
  Last Heartbeat: 2019-02-27T15:03:45Z
  _id:            resource_manager@hostname
  _ns:            workers
  Last Heartbeat: 2019-02-27T15:03:48Z
  _id:            reserved_resource_worker-0@hostname
  _ns:            workers
  Last Heartbeat: 2019-02-27T15:03:48Z
Messaging Connection:  
  Connected: True
Versions:              
  Platform Version: 2.18.1

[root@hostname tmp]# cat /etc/redhat-release 
CentOS Linux release 7.6.1810 (Core) 

#8 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF