Project

Profile

Help

Task #3220

closed

Story #3209: As a user, I have Repository Versions

Expand plugin writer's guide to include RepositoryVersion creating actions (including sync)

Added by dkliban@redhat.com almost 5 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Documentation, Plugin Template
Sprint:
Sprint 42
Quarter:

Description

The documentation for plugin writers needs to explain that a new repository version should be created any time the content of a repository changes.

There are two places to consider.

A high level explanation of the options (currently, just using RepositoryVersion as a context manager) should be included in the sync documentation in the plugin-writer docs.
https://github.com/asmacdo/plugin_template/blob/add-plugin-writer-docs/docs/plugin-writer/tasks/add-remove.rst

A specific example is included in the sync task in the plugin_template. Please check that the comments are sufficient, and that they match the explanation in the plugin writer docs.
https://github.com/asmacdo/plugin_template/blob/add-plugin-writer-docs/pulp_plugin_template/app/tasks/synchronizing.py#L39

Given that more work is being done with the DeclarativeVersion, keep in mind that what is added by this task will be expanded/revised soon.

Do not include custom views in this task.


Related issues

Has duplicate Pulp - Story #3173: As a plugin author, I have documentation on how to implement a sync operation for my importerCLOSED - DUPLICATE

Actions
Copied to Pulp - Task #3298: Expand plugin writer's guide to include Publication creating actions (including publish)CLOSED - CURRENTRELEASECodeHeeler

Actions
Actions #1

Updated by dkliban@redhat.com almost 5 years ago

  • Parent task set to #3209
Actions #2

Updated by daviddavis almost 5 years ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes
Actions #3

Updated by dkliban@redhat.com almost 5 years ago

  • Blocked by Story #3173: As a plugin author, I have documentation on how to implement a sync operation for my importer added
Actions #4

Updated by dkliban@redhat.com almost 5 years ago

  • Blocked by deleted (Story #3173: As a plugin author, I have documentation on how to implement a sync operation for my importer)
Actions #5

Updated by amacdona@redhat.com almost 5 years ago

  • Is duplicate of Refactor #3074: Move sync logic from models to tasks added
Actions #6

Updated by amacdona@redhat.com almost 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #7

Updated by amacdona@redhat.com almost 5 years ago

  • Status changed from CLOSED - DUPLICATE to NEW
Actions #8

Updated by amacdona@redhat.com almost 5 years ago

  • Is duplicate of deleted (Refactor #3074: Move sync logic from models to tasks)
Actions #9

Updated by amacdona@redhat.com almost 5 years ago

  • Has duplicate Story #3173: As a plugin author, I have documentation on how to implement a sync operation for my importer added
Actions #10

Updated by amacdona@redhat.com almost 5 years ago

  • Subject changed from Expand plugin writer's guide to include repository versions to Expand plugin writer's guide to include RepositoryVersion creating actions (including sync)
  • Tags Pulp 3 added
Actions #11

Updated by amacdona@redhat.com almost 5 years ago

  • Copied to Task #3298: Expand plugin writer's guide to include Publication creating actions (including publish) added
Actions #12

Updated by amacdona@redhat.com almost 5 years ago

  • Groomed changed from Yes to No
Actions #13

Updated by amacdona@redhat.com over 4 years ago

  • Groomed changed from No to Yes
  • Tags Pulp 3 MVP added
Actions #14

Updated by amacdona@redhat.com over 4 years ago

  • Sprint set to Sprint 35
Actions #15

Updated by amacdona@redhat.com over 4 years ago

  • Tags Documentation added
Actions #16

Updated by dkliban@redhat.com over 4 years ago

  • Sprint/Milestone set to 3.0.0
Actions #17

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 35 to Sprint 36
Actions #18

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 36 to Sprint 37
Actions #19

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 37 to Sprint 38
Actions #20

Updated by amacdona@redhat.com over 4 years ago

  • Project changed from Pulp to 27
  • Sprint/Milestone deleted (3.0.0)
Actions #21

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 38 to Sprint 39
Actions #22

Updated by amacdona@redhat.com over 4 years ago

  • Description updated (diff)
Actions #23

Updated by amacdona@redhat.com over 4 years ago

When this story is complete, please open a PR against my feature branch for plugin-writer docs

https://github.com/asmacdo/plugin_template/tree/add-plugin-writer-docs

Actions #24

Updated by bizhang over 4 years ago

  • Status changed from NEW to ASSIGNED
Actions #25

Updated by bizhang over 4 years ago

  • Status changed from ASSIGNED to POST
Actions #26

Updated by daviddavis over 4 years ago

  • Assignee set to bizhang
Actions #27

Updated by dkliban@redhat.com over 4 years ago

  • Sprint changed from Sprint 39 to Sprint 40
Actions #28

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 40 to Sprint 41
Actions #29

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 41 to Sprint 42
Actions #30

Updated by dalley over 4 years ago

  • Status changed from POST to MODIFIED
Actions #31

Updated by werwty about 4 years ago

  • % Done changed from 0 to 100

Applied in changeset commit:d73ec31f75db6dfdebab8742982ea350cb0475a8.

Actions #32

Updated by bmbouter over 3 years ago

  • Tags deleted (Pulp 3, Pulp 3 MVP)
Actions #33

Updated by bmbouter over 3 years ago

  • Tags Plugin Template added
Actions #34

Updated by bmbouter over 3 years ago

  • Project changed from 27 to Pulp

The plugin template Redmine project is being consolidated into the Pulp Redmine project so all issues are being moved over.

Actions #35

Updated by bmbouter over 3 years ago

  • Sprint/Milestone set to 3.0.0
Actions #36

Updated by bmbouter almost 3 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF