Project

Profile

Help

Issue #2952

Use 'endpoint' in /etc/crane.conf in all response headers

Added by tomckay@redhat.com over 3 years ago. Updated almost 2 years ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Crane:
2.0.0
Platform Release:
Target Release - Crane:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Setting up an openshift instance to point at foreman (w/ pulp-2.12.2) fails to pull images because it cannot resolve the foreman hostname. The registry specified in openshift was by IP address.

daviddavis pointed me to this line https://github.com/pulp/crane/blob/67503493a2af22ea809f0880dd11b3b76f908a15/crane/views/v1.py#L91

python-crane-2.0.2-1.el7sat.noarch

History

#1 Updated by daviddavis over 3 years ago

@thomasmckay, I think we fixed your issue last time by setting the url on the repo's distributor or in server.conf. So I think this change is no longer needed. Can you confirm?

Thanks.

#2 Updated by mhrivnak over 3 years ago

  • Status changed from NEW to CLOSED - NOTABUG

I think this ended up being "not a bug". Tom, be in touch if you think there's still an issue here.

#3 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF