Project

Profile

Help

Issue #2945

Node sync only syncs metadata and not the rpm's.

Added by dsouza.rohan06 over 4 years ago. Updated almost 3 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.13.3
Platform Release:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

1. ) For eg. I create a repo on the parent node here:

_[root@pulpserver ~]# pulp-admin rpm repo create --repo-id myown --feed file:///mnt/rpms/myown
Successfully created repository [myown]

[root@pulpserver ~]# pulp-admin repo list
--------------------------------------------------------------------
Repositories
--------------------------------------------------------------------

Id: myown
Display Name: None
Description: None
Content Unit Counts: _

*2. )*Now, enabling and publishing the repo;

_[root@pulpserver ~]# pulp-admin node repo enable --repo-id myown
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

Repository enabled.

Note: Repository [ myown ] will not be available for node synchronization until
published. See: the 'node repo publish' command.

Warning: enabling with auto-publish may degrade repository synchronization
performance.

[root@pulpserver ~]# pulp-admin node repo publish --repo-id myown
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Publish succeeded._

3. ) On child node, registered consumer using name 'child-1', activated the node and binded it with the repo mentioned on the parent node.

_[root@pulp-slave-server ~]# pulp-consumer status
This consumer is registered to the server [pulpserver.local] with the ID
[child-1].

[root@pulp-slave-server ~]# pulp-consumer node activate
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

This consumer already activated. No action performed.

[root@pulp-slave-server ~]# pulp-consumer node bind --repo-id myown
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

Node bind succeeded.

Note: Repository [ myown ] will be included in node synchronization.
_
4. ) Now on the parent node, synchronizing the child node.

_[root@pulpserver ~]# pulp-admin node sync run --node-id child-1
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

This command may be exited via ctrl+c without affecting the request.

(1/1) Repository: myown
[==================================================] 100%

Synchronization succeeded

--------------------------------------------------------------------
Child Node Synchronization
--------------------------------------------------------------------

Repository:
Action: Added
Content Sources:
Downloads:
Total Sources: 0
Id: myown
Units: <==== Note that the RPM's are not being show here.
Added: 0
Removed: 0
Updated: 0

[root@pulpserver ~]# pulp-admin node repo list
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

--------------------------------------------------------------------
Enabled Repositories
--------------------------------------------------------------------

Id: myown
Display Name: None
Description: None
Content Unit Counts:_ <==== Note that the RPM's are not being show here.

***********************************************************************************************

Now, the issue I'm facing here is that the rpm's are not getting synced on the chiild node. The child node will just have the metadata of the parent node

[root@pulp-slave-server repodata]# pwd
/var/lib/pulp/published/yum/master/yum_distributor/myown/1501349553.04/repodata

[root@pulp-slave-server repodata]# ls
0c44de7488b3261d43145d9d835f63fca51bbcc852c89fd099b77ea311e46bdd-primary.xml.gz
a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
b71d424e9e2b09a47ebebc0640f66d11545a72bbfe1a64283db3b812375e38f6-updateinfo.xml.gz
e12b78519f2bfbec2e57dbf7f6c1afe7c8099d8e9893ad3d3cb5cc8e5f0f32f4-other.xml.gz
f8759f424f2aa1062de1591a433cd1c7ae4a301dfcd93eec8b1b3aa112b20ae8-filelists.xml.gz
repomd.xml

I even want my RPM's to get synced on the child node.

Post step 1 , if I do a rpm repo sync run and a rpm repo publish run , I can see the RPM's added but when doing a pulp-admin node repo publish --repo-id myown, it throws me the following error:

[root@pulpserver ~]# pulp-admin node repo publish --repo-id myown
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Publish failed. See: pulp log for details.

A verbose output can be found here: http://paste.ubuntu.com/25198989/
I can find the following in journalctl logs: http://paste.ubuntu.com/25199004/

Kindly help me fix the issue.

Please note that selinux and firewalld have been disabled and stopped on both the parent as well as the child node.

History

#1 Updated by dsouza.rohan06 over 4 years ago

May I please have an update on this.

#2 Updated by ttereshc over 4 years ago

  • Category deleted (23)

The #2928 issue error seems to be exactly the same, and reporter said that it was solved.
Rohan, can you check if solution for the other issue (#2928) helps here and what was the solution?

According to the traceback, compressed rpm repodata is not handleed correctly during publish. It's probably nodes specific.

#3 Updated by ttereshc over 4 years ago

  • Severity changed from 3. High to 1. Low
  • Triaged changed from No to Yes

#4 Updated by dsouza.rohan06 over 4 years ago

Hi, I was the reporter of 2928 . Like I mentioned above, node sync and rpm sync cannot be used together. Pulp throws an error which has been mentioned above. Hence, only using node sync, works without any error, however, it does not sync the rpm's in the repo. Only the metadata is getting synced.

So is this a bug with node sync. I have followed the exact documentation mentioned here: https://docs.pulpproject.org/user-guide/nodes.html

Please look at the output of node sync:

root@pulpserver ~]# pulp-admin node sync run --node-id child-1
Warning: this Nodes command is deprecated as the Nodes functionality will be
removed from Pulp 3.0.

This command may be exited via ctrl+c without affecting the request.

(1/1) Repository: myown
[==================================================] 100%

Synchronization succeeded

--------------------------------------------------------------------
Child Node Synchronization
--------------------------------------------------------------------

Repository:
Action: Added
Content Sources:
Downloads:
Total Sources: 0
Id: myown
Units: <==== Note that the RPM's are not being show here.
Added: 0
Removed: 0
Updated: 0

We are using an older version of pulp i.e version 1.1 wherein the node sync also syncs the rpms. Kindly let us know where are we going wrong. There is no error we receive with node sync. However, if we do an rpm sync before, only then we get an error with node sync.

I have given a detailed list as to how I have created a repo, enabled it, published it and then synced it with the child node above(in my first post). I did not face any issues. However, my rpm's are not getting updated. Please help me fix this issue.

On the child node:

[root@pulp-slave ~]# pulp-admin repo list
--------------------------------------------------------------------
Repositories
--------------------------------------------------------------------

Id: centos7
Display Name: None
Description: None
Content Unit Counts: <==== Note that the RPM's are not being show here as they have not got synced.

Kindly let us know what would be the optimal solution.

#5 Updated by bmbouter almost 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#6 Updated by bmbouter almost 3 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#7 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF