Project

Profile

Help

Issue #2809

Logging fails in case of non-ascii characters in the url

Added by ehalcik almost 2 years ago. Updated 5 days ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Sprint/Milestone:
-
Severity:
1. Low
Version - Nectar:
Platform Release:
Blocks Release:
Target Release - Nectar:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

i have a repo defined as :

pulp-admin rpm repo create --repo-id=oel-addons-x86_64-6 --feed=http://yum.oracle.com/​repo/​OracleLinux/​OL6/​addons/​x86_64/  --relative-url=addons/oel/x86_64/6 --description "oel-addons-x86_64-6" --serve-http=true

Issuing the command pulp-admin rpm repo sync run --repo-id=oel-addons-x86_64-6 results in this error.

Task Failed

'ascii' codec can't decode byte 0xc3 in position 48: ordinal not in range(128)

/var/log/messages says this:

pulp: celery.worker.job:ERROR: (14295-74720) Task pulp.server.managers.repo.sync.sync[7f04fd3b-d2d8-4b8b-ad1a-f30816a6e095] raised unexpected: UnicodeDecodeError('ascii', 'Downloading metadata from http://yum.oracle.com/\xc3\xa2\xc2\x80\xc2\x8brepo/\xc3\xa2\xc2\x80\xc2\x8bOracleLinux/\xc3\xa2\xc2\x80\xc2\x8bOL6/\xc3\xa2\xc2\x80\xc2\x8baddons/\xc3\xa2\xc2\x80\xc2\x8bx86_64/.', 48, 49, 'ordinal not in range(128)')

My other repos sync just fine.

screenshot_1_1554358461.png (1.11 KB) ericbanaa19, 04/04/2019 08:14 AM screenshot_1_1554358461.png
screenshot_2_1554358543.png (1.42 KB) ericbanaa19, 04/04/2019 08:15 AM screenshot_2_1554358543.png
screenshot_3_1554358636.png (1.11 KB) ericbanaa19, 04/04/2019 08:17 AM screenshot_3_1554358636.png
screenshot_1_1554378245.png (681 Bytes) mandyangelica, 04/04/2019 01:44 PM screenshot_1_1554378245.png
screenshot_2_1554378265.png (681 Bytes) mandyangelica, 04/04/2019 01:44 PM screenshot_2_1554378265.png
screenshot_5_1554841989.png (629 Bytes) tahminakhan, 04/09/2019 10:33 PM screenshot_5_1554841989.png
clipboard-201905141432-3w6vb.png (1.96 KB) carpetcleaningmelbourne, 05/14/2019 11:02 AM clipboard-201905141432-3w6vb.png
clipboard-201905141433-ddzho.png (841 Bytes) carpetcleaningmelbourne, 05/14/2019 11:03 AM clipboard-201905141433-ddzho.png
clipboard-201905201408-6nexq.png (2.14 KB) melbournecentralcleaning, 05/20/2019 10:38 AM clipboard-201905201408-6nexq.png
250
250
250
250
250
250
250
250
250

History

#1 Updated by bmbouter almost 2 years ago

  • Description updated (diff)

Add some escaping to the description.

#2 Updated by bmbouter almost 2 years ago

I was able to reproduce this from the commands in the ticket. Here is the traceback I received.

nectar.downloaders.threaded:ERROR: (14604-28416) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128) 
nectar.downloaders.threaded:ERROR: (14604-28416) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: (14604-28416)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: (14604-28416)     _logger.debug("Attempting to connect to {url}.".format(url=request.url)) 
nectar.downloaders.threaded:ERROR: (14604-28416) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128) 
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128) 
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720)     _logger.debug("Attempting to connect to {url}.".format(url=request.url))
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: (14604-28416) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: (14604-28416) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: (14604-28416)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: (14604-28416)     _logger.debug("Attempting to connect to {url}.".format(url=request.url))
nectar.downloaders.threaded:ERROR: (14604-28416) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720)     _logger.debug("Attempting to connect to {url}.".format(url=request.url))
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: (14604-35712) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: (14604-35712) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: (14604-35712)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: (14604-35712)     _logger.debug("Attempting to connect to {url}.".format(url=request.url))
nectar.downloaders.threaded:ERROR: (14604-35712) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720)     _logger.debug("Attempting to connect to {url}.".format(url=request.url))
nectar.downloaders.threaded:ERROR: [246f51cc] (14604-42720) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: (14604-28416) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: (14604-28416) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: (14604-28416)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: (14604-28416)     _logger.debug("Attempting to connect to {url}.".format(url=request.url)) 
nectar.downloaders.threaded:ERROR: (14604-28416) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
pulp_rpm.plugins.importers.yum.sync:INFO: [246f51cc] Downloading additional units.
nectar.downloaders.threaded:ERROR: (14604-35712) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128) 
nectar.downloaders.threaded:ERROR: (14604-35712) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: (14604-35712)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: (14604-35712)     _logger.debug("Attempting to connect to {url}.".format(url=request.url)) 
nectar.downloaders.threaded:ERROR: (14604-35712) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128) 
nectar.downloaders.threaded:ERROR: (14604-28416) 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)
nectar.downloaders.threaded:ERROR: (14604-28416) Traceback (most recent call last):
nectar.downloaders.threaded:ERROR: (14604-28416)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 267, in _fetch
nectar.downloaders.threaded:ERROR: (14604-28416)     _logger.debug("Attempting to connect to {url}.".format(url=request.url))
nectar.downloaders.threaded:ERROR: (14604-28416) UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-24: ordinal not in range(128)

#3 Updated by bizhang almost 2 years ago

  • Tags deleted (Pulp 3)

#4 Updated by ttereshc almost 2 years ago

@ehalcik, the issue is in the encoding of the url which was provided to pulp I guess.
You can see that there are some additional characters in url:

$ od -a 
http://yum.oracle.com/​repo/​OracleLinux/​OL6/​addons/​x86_64/
0000000   h   t   t   p   :   /   /   y   u   m   .   o   r   a   c   l
0000020   e   .   c   o   m   /   b nul  vt   r   e   p   o   /   b nul
0000040  vt   O   r   a   c   l   e   L   i   n   u   x   /   b nul  vt
0000060   O   L   6   /   b nul  vt   a   d   d   o   n   s   /   b nul

You can update your repo with a proper feed (without any additional characters), just copy-paste this:

pulp-admin rpm repo update --feed http://yum.oracle.com/repo/OracleLinux/OL6/addons/x86_64/ --repo-id oel-addons-x86_64-6

To double-check this ^ url:
$ od -a 
http://yum.oracle.com/repo/OracleLinux/OL6/addons/x86_64/
0000000   h   t   t   p   :   /   /   y   u   m   .   o   r   a   c   l
0000020   e   .   c   o   m   /   r   e   p   o   /   O   r   a   c   l
0000040   e   L   i   n   u   x   /   O   L   6   /   a   d   d   o   n

Then re-sync, it works for me.

#5 Updated by ehalcik almost 2 years ago

Thank you ! I'll watch for the additional characters next time .. This is now working for me

#6 Updated by ttereshc almost 2 years ago

  • Project changed from Pulp to Nectar
  • Subject changed from getting an error "'ascii' codec can't decode byte 0xc3 in position 48: ordinal not in range(128)" when syncing a repository to Logging fails in case of non-ascii characters in the url
  • Category deleted (pulp-admin)
  • Priority changed from Normal to Low
  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes

#7 Updated by pthomas@redhat.com almost 2 years ago

  • Smash Test set to 684

#8 Updated by sarahtaylor 4 months ago

Should we have special character in URL with Unicode? And I that good idea special character with URL Unicode I have to Write My Dissertation upon Unicode but I don't have any kind of information Unicode.

#9 Updated by thomas 3 months ago

I have a craze to learn about this uni-code I saw many tutorials of it but didn't get valid information or maybe I am not getting this in a perfect way. I hope with the help of guidance of Buy Essay at Cheap hope to achieve great information and it makes me clear concept about Unicode.

#10 Updated by danieljamez 2 months ago

Best top dissertation writing services uk at cheapable rates, and also academic papers, research writing and other writing services. Never compromise with your future contact us right now.

https://www.dissertationpros.co.uk/

#11 Updated by WillardZheng 2 months ago

I am hoping with the assist of steering of desire to gain remarkable statistics and it makes me clean idea approximately Unicode. I have a craze to study UK Dissertation Editing Service this uni-code I noticed many tutorials of it but didn't get valid information or maybe I am not getting this in a really perfect manner.

#12 Updated by danieljamez about 2 months ago

The student from around the world don't understand the power of their Education, every student should get attention to their academic result before it's get too late. https://educationpros.edublogs.org/

#13 Updated by ericbanaa19 about 2 months ago

250
250
250

Except you have the posh of controlling how your customers use your code, you need to always, usually, usually convert to byte str earlier than outputting strings to the terminal or to an All Assignment Help

#14 Updated by mandyangelica about 2 months ago

250
250

If your code is closely involved with utilizing things which are bytes, you are able to do the opposite and convert all textual content into byte str at the border and only convert to Unicode whilst you want it for passing to one other library or performing string operations on it In both case, the major thing is to decide on a default style for strings Write my dissertation for me UK Usage and keep on with it during your code. When you combine the types it turns into a lot less difficult to function on a string with a function that may most effective use the other sort by means of mistake.

#15 Updated by tahminakhan about 2 months ago

250

Latex sleeping pad audits encourages you select the best bedding. Distinctive pieces of the body need diverse help while we are snoozing. A large portion of the latex sleeping cushions today are layered with more than latex layer on the top. The best sleeping cushions utilize both adjustable foam and latex.

#16 Updated by tahminakhan about 2 months ago

Latex sleeping pad audits encourages you select the best bedding. Distinctive pieces of the body need diverse help while we are snoozing. A large portion of the latex sleeping cushions today are layered with more than latex layer on the top. The best sleeping cushions utilize both adjustable foam and latex. best latex mattress

#17 Updated by bmbouter about 1 month ago

  • Status changed from NEW to CLOSED - WONTFIX

#18 Updated by bmbouter about 1 month ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#19 Updated by bmbouter about 1 month ago

  • Tags Pulp 2 added

#21 Updated by tahminakhan 28 days ago

Latex sleeping pad audits encourages you select the best bedding. Distinctive pieces of the body need diverse help while we are snoozing. A large portion of the latex sleeping cushions today are layered with more than latex layer on the top. The best sleeping cushions utilize both adjustable foam and latex. [https://topnaturalmattresses.com/best-latex-mattress/ best latex mattress]

#22 Updated by Garretjacob 27 days ago

Hi,

#23 Updated by carpetcleaningmelbourne 12 days ago

250
250

Are you looking for best carpet cleaners Melbourne? Drymaster carpet cleaning is professional carpet cleaning agency ensure great service. For Carpet cleaning Melbourne, contact us.
https://carpetcleaning.com.au/melbourne/
https://carpetcleaning.com.au/upholstery-cleaning-melbourne/

#26 Updated by QubJordan 5 days ago

Amazing Post. Visit https://fauxncotton.com/Assassins-Creed-Syndicate-Jacob-Frye-Coat and the content and material you have used is pretty great.

Please register to edit this issue

Also available in: Atom PDF