Project

Profile

Help

Issue #2785

closed

pulp-admin rpm repo create with --retain-old-count option does not seem to work

Added by aurelien about 5 years ago. Updated about 3 years ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.11.0
Platform Release:
OS:
RHEL 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

pulp rpm repo create with --count option does not seems to provide last package after sync.

pulp-admin rpm repo create --repo-id=rhel-7-bla --retain-old-count 2

pulp-admin rpm repo update --repo-id=rhel-7-bla \
           --relative-url /rhel/7Server/x86_64/bla/os \
           --proxy-host=proxy --proxy-port=* \
           --feed=https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os \
           --feed-ca-cert=/etc/rhsm/ca/redhat-uep.pem \
           --feed-key=/etc/pki/entitlement/**-key.pem \
           --feed-cert=/etc/pki/entitlement/**.pem

pulp-admin rpm repo sync run --repo-id rhel-7-bla
pulp-admin rpm repo publish run --repo-id rhel-7-bla

get 3 packages and provide them but they are not the last one.

Name        : pulp-server^O
Arch        : noarch
Version     : 2.11.0
Release     : 1.el7
Actions #1

Updated by ttereshc about 5 years ago

  • Subject changed from pulp rpm repo create with --count option does not seems to works to pulp-admin rpm repo create with --retain-old-count option does not seem to work
Actions #3

Updated by bmbouter about 5 years ago

  • Description updated (diff)
Actions #4

Updated by ipanova@redhat.com about 5 years ago

I was not able to reproduce this on master, with retain-old-count 2, i get 3 packages, cheking with remote source they are the 3 latest ones:


$ pulp-admin rpm repo create --repo-id drpm-repo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/test_drpm_repo/ --retain-old-count 2
$ pulp-admin rpm repo sync  run --repo-id drpm-repo
$ pulp-admin rpm repo content rpm --repo-id drpm-repo --match='filename=yum-cron.*' --fields=filename

Filename:     yum-cron-3.4.3-19.fc16.noarch.rpm

Filename:     yum-cron-3.4.3-22.fc16.noarch.rpm

Filename:     yum-cron-3.4.3-20.fc16.noarch.rpm
Actions #5

Updated by ipanova@redhat.com about 5 years ago

switching to 2.11-dev branch i get same results as mentioned above.

Actions #6

Updated by ipanova@redhat.com about 5 years ago

can you please provide the list of the packages you see and the ones you expect to see?

Actions #7

Updated by aurelien about 5 years ago

the kernel one of the redhat (for example, like all the redhat core repo)
For the moment I have clear the situation by restarting the services pulp, but ipanova from IRC told me that it is not a solution.
I have do that because sync all the repo seems to have create a stack of pulp service and eat the swap.
so, i will keep an eye on the situation and bring back more information if the trouble comes once again.
If in 2 weeks it does not comes back ... I will close this post.

Actions #9

Updated by aurelien about 5 years ago

it happen on the rhel7 between the retain and the non retain one ... all last package was not present before restarting all pulp services

Actions #10

Updated by ipanova@redhat.com about 5 years ago

so i synced exactly same repo with exactly same retain-old-count. i successfully get the version which you were missing in some of the repos kernel-3.10.0-514.21.1.el7.x86_64.rpm

$ pulp-admin rpm repo content rpm --repo-id repo1 --match='filename=kernel-3.10.0-514*'|grep -i filename
Warning: path should have mode 0700 because it may contain sensitive information: /home/ipanova/.pulp/

Filename:     kernel-3.10.0-514.10.2.el7.x86_64.rpm
Filename:     kernel-3.10.0-514.16.1.el7.x86_64.rpm
Filename:     kernel-3.10.0-514.21.1.el7.x86_64.rpm

The reason that you were not getting the latest version is because it was added on May 10 2017, and your sync most probably happened before that date when this version still was not in the upstream repo.

I suggest to close this as not a bug.

Actions #11

Updated by ipanova@redhat.com about 5 years ago

  • Status changed from NEW to CLOSED - NOTABUG

closing this as not a bug, in case you think problem still persists feel free to re-open this.

Actions #12

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF