Project

Profile

Help

Issue #2623

Errata publish performace degradation

Added by ttereshc about 1 year ago. Updated 3 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Severity:
2. Medium
Version:
Platform Release:
2.12.2
Blocks Release:
2.12.z, 2.13.z
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 16

Description

pulp-admin rpm repo create --repo-id epel7 --relative-url epel7 --feed https://dl.fedoraproject.org/pub/epel/7/x86_64/ --download-policy on_demand
pulp-admin rpm repo sync  run --repo-id epel7

Notice that publish of errata is extremely slow, several seconds per each erratum.
My tests shows that it is because of this recent errata fix.


Related issues

Related to RPM Support - Issue #2560: Non-unique collection names in erratum pkglists causes yum not to show all packages CLOSED - CURRENTRELEASE Actions

Associated revisions

Revision f93b8dc9 View on GitHub
Added by semyers about 1 year ago

Don't rebuild repo_unit_nevra for every unit

This made errata publish very slow.

closes #2623
https://pulp.plan.io/issues/2623

History

#1 Updated by semyers about 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to semyers

I feel like we worked pretty hard to keep the performance the same, so I'll take a look. If the cause of the slowdown is not obvious or simple to fix then I propose to just revert my PR, fix the bug the initial (and terrible way) I did, open up a separate refactor issue referencing the reverted commit, and we can get the new errata behavior in formally with 2.13.

#2 Updated by bizhang about 1 year ago

  • Sprint/Milestone set to 34
  • Triaged changed from No to Yes

#3 Updated by semyers about 1 year ago

  • Related to Issue #2560: Non-unique collection names in erratum pkglists causes yum not to show all packages added

#4 Updated by semyers about 1 year ago

  • Status changed from ASSIGNED to POST
  • Blocks Release 2.12.z, 2.13.z added

#5 Updated by semyers about 1 year ago

  • Status changed from POST to MODIFIED

#6 Updated by semyers about 1 year ago

  • Platform Release set to 2.12.2

#7 Updated by semyers about 1 year ago

  • Status changed from MODIFIED to ON_QA

#8 Updated by semyers about 1 year ago

This is a little odd, since it was broken and fixed between the 2.12.1 and 2.12.2 releases. If we want to verify this, it would be to ensure there's little to no difference between the performance of publishing errata in 2.12.1 and 2.12.2.

#9 Updated by bizhang about 1 year ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

#12 Updated by bmbouter 3 months ago

  • Sprint set to Sprint 16

#13 Updated by bmbouter 3 months ago

  • Sprint/Milestone deleted (34)

Please register to edit this issue

Also available in: Atom PDF