Project

Profile

Help

Issue #2551

Pulp task error messages should be more informative

Added by tomckay@redhat.com over 3 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.11.0
Platform Release:
2.12.2
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 15
Quarter:

Description

Syncing a repo from katello an error was reported:
PLP0000: The task status 23a81cbf-547b-4c16-9eba-0bf478399da1 exited immediately for some reason. Marking as errored. Check the logs for more details

the /var/log/messages had the detailed

celery.worker.job:ERROR: (15661-67328) WorkerLostError: Worker exited prematurely: signal 6 (SIGIOT)

pulp-2.11.0-1.el7

Associated revisions

Revision c0ea5ee4 View on GitHub
Added by jortel@redhat.com over 3 years ago

Improved logging of worker abnormal termination. closes #2551

Revision c0ea5ee4 View on GitHub
Added by jortel@redhat.com over 3 years ago

Improved logging of worker abnormal termination. closes #2551

History

#1 Updated by bmbouter over 3 years ago

This usually means that while Pulp was running, a library it was calling into experienced a fatal exception. For instance a segfault, OOM, or memory allocation issue. Some searching of the web indicates that it could fail to allocate necessary memory which would be an environmental issue. Is this problem reproducible? I suspect not, but I want to confirm.

It's very highly unlikely to be something a Pulp code change would fix, but we can help investigate since you experienced it using Pulp. Since Python is interpreted and it's highly unlikley to be a bug in cPython, it's either going to be an environmental problem or a bug in a third party library.

As the bug is written now, it couldn't be accepted. Can some reproducer steps be added? Either API calls or pulp-admin commands would do.

#2 Updated by tomckay@redhat.com over 3 years ago

Sorry, I forgot to include the reason why I reported this issue: The generic PLP0000 message is not as useful as conveying the actual error that is shown in /var/log/messages up to the user. I was told that pulp devs desired to know the cases of PLP0000 encountered in katello tooling so that better info could be passed up.

The source of the underlying issue itself is unknown to me at this time. I will file a new issue with details for reproducing that.

#3 Updated by bmbouter over 3 years ago

Ohhhhh. Yes I see exactly what you mean. That makes sense. My comments above are more pertinent to the issue tracking the root cause. Thanks for clarifying.

#5 Updated by bizhang over 3 years ago

  • Subject changed from PLP0000 error reported for "celery.worker.job:ERROR: (15661-67328) WorkerLostError: Worker exited prematurely: signal 6 (SIGIOT)" to Pulp task error messages should be more informative
  • Sprint/Milestone set to 32
  • Triaged changed from No to Yes

#6 Updated by mhrivnak over 3 years ago

  • Sprint/Milestone changed from 32 to 33

#7 Updated by jortel@redhat.com over 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com

#8 Updated by jortel@redhat.com over 3 years ago

  • Status changed from ASSIGNED to POST

#9 Updated by jortel@redhat.com over 3 years ago

  • Status changed from POST to MODIFIED

#10 Updated by semyers over 3 years ago

  • Platform Release set to 2.12.2

#11 Updated by semyers over 3 years ago

  • Status changed from MODIFIED to 5

#12 Updated by bizhang over 3 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#13 Updated by bmbouter over 2 years ago

  • Sprint set to Sprint 15

#14 Updated by bmbouter over 2 years ago

  • Sprint/Milestone deleted (33)

#15 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF