Project

Profile

Help

Story #249

[RFE] nested pulp-admin sessions

Added by igulina@redhat.com almost 7 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1134510 ++

Description of problem:

Description of problem:

Pulp-admin supports login command from one user to another without prior logout.
So far, every new login command rewrite/removes the granted certificate of the previous user. After logout command the user doesn't have his session back with a granted certificate anymore. So s/he has to login again.

Nested sessions like in bash shell would be nice feature especially for users with admin roles.

Steps to Reproduce:

pulp-admin login -u admin -p admin

Successfully logged in. Session certificate will expire at Oct 9 20:19:42 2015
GMT.

pulp-admin repo list

--------------------------------------------------------------------
Repositories
--------------------------------------------------------------------

Id: gena
Display Name: gena
Description: None
Content Unit Counts:

pulp-admin login -u user1 -p test1

Successfully logged in. Session certificate will expire at Oct 9 20:20:23 2015
GMT.

pulp-admin repo list

--------------------------------------------------------------------
Repositories
--------------------------------------------------------------------

Insufficient Permissions

The user does not have the appropriate permissions to execute this command.

pulp-admin logout

Session certificate successfully removed.

pulp-admin repo list

--------------------------------------------------------------------
Repositories
--------------------------------------------------------------------

Authentication Failed

Use the login command to authenticate with the server and download a session
certificate for use in future calls to this script. If credentials were
specified, please double check the username and password and attempt the request
again.

Expected results:

1. Log as user #1
2. Execute some pulp-admin commands without -u/-p options
3. Log as user #2 without logout from the user #1 session
4. Execute some pulp-admin commands without -u/-p options as user #2
5. logout
6. return back to the session of user #1 and be able to execute pulp-admin commands without -u/-p options since the certificate of user #1 should be still valid

History

#1 Updated by mhrivnak over 6 years ago

  • Priority changed from Normal to Low

Can you think of any other applications that support this? It seems like an unusual feature to me.

#2 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#3 Updated by bmbouter over 2 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF