Project

Profile

Help

Story #238

[RFE] allow pulp-admin to set export_dir and auto_publish for export distributor

Added by justin.garrison@disneyanimation.com almost 6 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1112859 ++

Description of problem:

Description of problem: When trying to auto publish a repo using the export distributor there is no way to configure it except for via the API. Pulp-admin allows for --export and --export_dir but those must be run interactively and cannot be scheduled/auto published

Version-Release number of selected component (if applicable): 2.3

How reproducible: always

Steps to Reproduce:
1. create repo
2. use pulp-admin --export will only run export one time and is not scheduled. Auto publish does not have an option in pulp-admin

Actual results: export_dir is not configured and not saved in the database. because export_dir is not saved this causes exports to publish an iso to http(s) instead of exporting the packages to the filesystem

Expected results: repo exported to the filesystem after sync (auto_publish)

Additional info: Using the API the setting is configurable with
curl -E ~/pulp.pem -k -X PUT -d '{"distributor_config": {}, "delta": {"export_dir": "/repos/", "auto_publish": true }}' https://pulp/pulp/api/v2/repositories/rhel-7-workstation-optional-rpms-x86_64/distributors/export_distributor/

the request is accepted but upon retrieving the settings the export_dir is still not set

curl -E ~/pulp.pem -k -X GET https://pulp/pulp/api/v2/repositories/rhel-7-workstation-optional-rpms-x86_64/distributors/export_distributor/

{
"_id": {
"$oid": "53a9a36abbea5770c8d1cd42"
},
"_ns": "repo_distributors",
"auto_publish": true,
"config": {
"http": false,
"https": false
},
"distributor_type_id": "export_distributor",
"id": "export_distributor",
"last_publish": null,
"repo_id": "rhel-7-workstation-optional-rpms-x86_64",
"scheduled_publishes": [],
"scratchpad": null
}

History

#1 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

#2 Updated by bmbouter over 1 year ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF