Project

Profile

Help

Story #230

closed

[RFE] The Puppet Forge downloader should download in parallel

Added by rbarlow over 7 years ago. Updated about 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1094524 ++

Description of problem:

The Puppet Forge downloader creates a Nectar downloader for each Puppet Module, rather than using Nectar's callback system and handing it a list of Modules to download. Because of this, there is no parallelization of Puppet Forge downloads, which is likely why it takes so long to synchronize Puppet Forge.

This was also the cause of #1082802[0].

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1082802


Related issues

Is duplicate of Puppet Support - Issue #1682: Puppet sync starts a new TCP connection for each package rather than poolingCLOSED - WONTFIXActions
Actions #1

Updated by rbarlow over 6 years ago

  • Is duplicate of Issue #1682: Puppet sync starts a new TCP connection for each package rather than pooling added
Actions #2

Updated by rbarlow over 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

The newer bug report was better.

Actions #3

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF