Project

Profile

Help

Story #216

As a user, all RPM NVRAs are unique per repo

Added by dgregor@redhat.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Low
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1057241 ++

Description of problem:

Pulp supports having multiple RPMs that have the same name-version-release.architecture values. This is good in a number of cases. However, we never want to have both the beta-signed and gold-signed copies of an RPM in the same repo at the same time if that repo being published as a Yum repository. It's undefined and unsupported to have different RPMs with the same NVRA in the same Yum repository.

Please modify the Yum distributor to fail when trying to publish a yum repository if there are multiple RPMs with the same NVRA.

Additionally, please modify the Yum importer to block imports (including copy operations) that would result in a repo having multiple RPMs with the same NVRA. Perhaps make this configurable for repos that aren't being published for Yum.

History

#1 Updated by rmcgover over 4 years ago

There was a similar issue, which has since been implemented: https://pulp.plan.io/issues/494

I think this issue could be closed as a duplicate.

(Note the implemented behavior on that one isn't quite what was requested here. This one asked to "block imports" (presumably fail) on attempting to import a different RPM with the same NEVRA as existing. The implemented behavior instead is that the new RPM will replace the old. But the critical issue is that having multiple RPM with same NEVRA and rendering a "corrupt" repo can't happen anymore, and current behavior looks fine.)

#2 Updated by bmbouter over 4 years ago

  • Subject changed from [RFE] ability to make RPM NVRAs unique per repo to As a user, all RPM NVRAs are unique per repo

I also agree this is a duplicate. I want to confirm with @smyers before closing.

#3 Updated by semyers over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

This is indeed a duplicate of #494. As indicated in the first comment, the implementation is a little different, in that Pulp will "Purge" packages with Duplicate NEVRA, preferring the package most recently synced or uploaded when a NEVRA conflict is encountered, rather than failing outright.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF