Project

Profile

Help

Issue #2131

create repo with different name but same feedurl causes an error

Added by Anonymous about 4 years ago. Updated 4 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.9.1
Platform Release:
OS:
RHEL 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Scenario: I would like to be able to freeze a repository up to a certain date. Some server require only 1 or 2 update a year.
Solution: Create a another repository that is synchronized manually on a specific date.

2016-08-04 17:11:27,116 - ERROR - Exception occurred:
        href:      /pulp/api/v2/repositories/
        method:    POST
        status:    400
        error:     Relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [oracle-rhel-6-x86_64-base] conflicts with existing relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [rhel-6-x86_64-base]
Relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [oracle-rhel-6-x86_64-base] conflicts with existing relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [rhel-6-x86_64-base]
        traceback: None
        data:      {u'args': [u'Relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [oracle-rhel-6-x86_64-base] conflicts with existing relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [rhel-6-x86_64-base]\nRelative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [oracle-rhel-6-x86_64-base] conflicts with existing relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [rhel-6-x86_64-base]'], u'error': {u'code': u'PLP0000', u'data': {}, u'description': u'Relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [oracle-rhel-6-x86_64-base] conflicts with existing relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [rhel-6-x86_64-base]\nRelative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [oracle-rhel-6-x86_64-base] conflicts with existing relative URL [content/dist/rhel/server/6/6.8/x86_64/os] for repository [rhel-6-x86_64-base]', u'sub_errors': []}}

History

#1 Updated by ipanova@redhat.com about 4 years ago

That's an expected conflict, if you want to use same feed in different repos just provide a unique relative-url.

#2 Updated by amacdona@redhat.com about 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

Since this is the expected behavior I am closing this. As ipanova mentioned, you can specify relative-url. Please feel free to reopen if you think we missed something.

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#4 Updated by bmbouter 4 months ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF