Project

Profile

Help

Issue #2100

Repositories with repo-id "search" cannot be updated or deleted

Added by amacdona@redhat.com over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

If the repo is named search, it's endpoint is /pulp/api/v2/repositories/search/ which conflicts with our search API.

If a user attempts to create this repo, there is no conflict.

If the user attempts to delete this repo, a 405 is returned because DELETE requests cannot go to the search API.

This has probably been around since as long as the search API and is therefore not a regression.

History

#1 Updated by amacdona@redhat.com over 5 years ago

  • Priority changed from Normal to Low
  • Triaged changed from No to Yes

#2 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#3 Updated by bmbouter over 2 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF