Project

Profile

Help

Issue #2074

Installing a new pulp consumer requires puppet open source?

Added by Anonymous over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.8.5
Platform Release:
OS:
RHEL 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I am trying to configure a new pulp-consumer on RHEL 7.x. Why there is a dependency on puppet package?

 yum groupinstall pulp-consumer-qpid
Loaded plugins: product-id, search-disabled-repos, subscription-manager
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
Resolving Dependencies
--> Running transaction check
---> Package pulp-agent.noarch 0:2.8.5-1.el7 will be installed
--> Processing Dependency: python-pulp-bindings = 2.8.5 for package: pulp-agent-2.8.5-1.el7.noarch
--> Processing Dependency: python-pulp-agent-lib = 2.8.5 for package: pulp-agent-2.8.5-1.el7.noarch
--> Processing Dependency: python-gofer >= 2.5 for package: pulp-agent-2.8.5-1.el7.noarch
--> Processing Dependency: gofer >= 2.5 for package: pulp-agent-2.8.5-1.el7.noarch
---> Package pulp-consumer-client.noarch 0:2.8.5-1.el7 will be installed
--> Processing Dependency: python-pulp-common = 2.8.5 for package: pulp-consumer-client-2.8.5-1.el7.noarch
--> Processing Dependency: python-pulp-client-lib = 2.8.5 for package: pulp-consumer-client-2.8.5-1.el7.noarch
---> Package pulp-puppet-consumer-extensions.noarch 0:2.8.5-1.el7 will be installed
--> Processing Dependency: python-pulp-puppet-common = 2.8.5 for package: pulp-puppet-consumer-extensions-2.8.5-1.el7.noarch
---> Package pulp-puppet-handlers.noarch 0:2.8.5-1.el7 will be installed
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers-2.8.5-1.el7.noarch
---> Package pulp-rpm-consumer-extensions.noarch 0:2.8.5-1.el7 will be installed
---> Package pulp-rpm-handlers.noarch 0:2.8.5-1.el7 will be installed
--> Processing Dependency: python-pulp-rpm-common = 2.8.5 for package: pulp-rpm-handlers-2.8.5-1.el7.noarch
---> Package pulp-rpm-yumplugins.noarch 0:2.8.5-1.el7 will be installed
---> Package python-gofer-qpid.noarch 0:2.7.6-1.el7 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.7.6-1.el7.noarch
--> Running transaction check
---> Package gofer.noarch 0:2.7.6-1.el7 will be installed
---> Package puppet.noarch 0:3.6.2-3.el7 will be installed
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: facter >= 1.6.6 for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: rubygem(rgen) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(shadow) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(release) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(augeas) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.6.2-3.el7.noarch
---> Package python-gofer.noarch 0:2.7.6-1.el7 will be installed
---> Package python-pulp-agent-lib.noarch 0:2.8.5-1.el7 will be installed
---> Package python-pulp-bindings.noarch 0:2.8.5-1.el7 will be installed
--> Processing Dependency: python-oauth2 >= 1.5.170-2.pulp for package: python-pulp-bindings-2.8.5-1.el7.noarch
---> Package python-pulp-client-lib.noarch 0:2.8.5-1.el7 will be installed
--> Processing Dependency: python-okaara >= 1.0.32 for package: python-pulp-client-lib-2.8.5-1.el7.noarch
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-client-lib-2.8.5-1.el7.noarch
---> Package python-pulp-common.noarch 0:2.8.5-1.el7 will be installed
---> Package python-pulp-puppet-common.noarch 0:2.8.5-1.el7 will be installed
---> Package python-pulp-rpm-common.noarch 0:2.8.5-1.el7 will be installed
---> Package python-qpid.noarch 0:0.32-13.el7 will be installed
--> Processing Dependency: python-qpid-common = 0.32-13.el7 for package: python-qpid-0.32-13.el7.noarch
--> Processing Dependency: python-saslwrapper for package: python-qpid-0.32-13.el7.noarch
--> Running transaction check
---> Package facter.x86_64 0:2.4.1-1.el7 will be installed
--> Processing Dependency: pciutils for package: facter-2.4.1-1.el7.x86_64
--> Processing Dependency: /usr/bin/ruby for package: facter-2.4.1-1.el7.x86_64
---> Package hiera.noarch 1:1.3.4-5.el7 will be installed
--> Processing Dependency: ruby(release) for package: 1:hiera-1.3.4-5.el7.noarch
---> Package puppet.noarch 0:3.6.2-3.el7 will be installed
--> Processing Dependency: ruby(selinux) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(release) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.6.2-3.el7.noarch
---> Package python-isodate.noarch 0:0.5.0-4.pulp.el7 will be installed
---> Package python-oauth2.noarch 0:1.5.211-8.el7 will be installed
--> Processing Dependency: python-simplejson for package: python-oauth2-1.5.211-8.el7.noarch
--> Processing Dependency: python-httplib2 for package: python-oauth2-1.5.211-8.el7.noarch
---> Package python-okaara.noarch 0:1.0.35-1.el7 will be installed
---> Package python-qpid-common.noarch 0:0.32-13.el7 will be installed
---> Package python-saslwrapper.x86_64 0:0.16-5.el7 will be installed
--> Processing Dependency: saslwrapper(x86-64) = 0.16-5.el7 for package: python-saslwrapper-0.16-5.el7.x86_64
--> Processing Dependency: libsaslwrapper.so.1()(64bit) for package: python-saslwrapper-0.16-5.el7.x86_64
---> Package ruby-augeas.x86_64 0:0.5.0-1.el7 will be installed
--> Processing Dependency: augeas-libs >= 1.0.0 for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: ruby(release) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.16.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.14.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libruby.so.2.0()(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
---> Package ruby-shadow.x86_64 0:1.4.1-23.el7 will be installed
--> Processing Dependency: ruby(release) for package: ruby-shadow-1.4.1-23.el7.x86_64
--> Processing Dependency: libruby.so.2.0()(64bit) for package: ruby-shadow-1.4.1-23.el7.x86_64
---> Package rubygem-rgen.noarch 0:0.6.6-2.el7 will be installed
--> Processing Dependency: ruby(rubygems) for package: rubygem-rgen-0.6.6-2.el7.noarch
--> Processing Dependency: ruby(release) for package: rubygem-rgen-0.6.6-2.el7.noarch
--> Running transaction check
---> Package facter.x86_64 0:2.4.1-1.el7 will be installed
--> Processing Dependency: pciutils for package: facter-2.4.1-1.el7.x86_64
--> Processing Dependency: /usr/bin/ruby for package: facter-2.4.1-1.el7.x86_64
---> Package hiera.noarch 1:1.3.4-5.el7 will be installed
--> Processing Dependency: ruby(release) for package: 1:hiera-1.3.4-5.el7.noarch
---> Package puppet.noarch 0:3.6.2-3.el7 will be installed
--> Processing Dependency: ruby(selinux) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(release) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.6.2-3.el7.noarch
---> Package python-httplib2.noarch 0:0.7.7-3.el7 will be installed
---> Package python-simplejson.x86_64 0:3.3.3-1.el7 will be installed
---> Package ruby-augeas.x86_64 0:0.5.0-1.el7 will be installed
--> Processing Dependency: augeas-libs >= 1.0.0 for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: ruby(release) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.16.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.14.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libruby.so.2.0()(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.5.0-1.el7.x86_64
---> Package ruby-shadow.x86_64 0:1.4.1-23.el7 will be installed
--> Processing Dependency: ruby(release) for package: ruby-shadow-1.4.1-23.el7.x86_64
--> Processing Dependency: libruby.so.2.0()(64bit) for package: ruby-shadow-1.4.1-23.el7.x86_64
---> Package rubygem-rgen.noarch 0:0.6.6-2.el7 will be installed
--> Processing Dependency: ruby(rubygems) for package: rubygem-rgen-0.6.6-2.el7.noarch
--> Processing Dependency: ruby(release) for package: rubygem-rgen-0.6.6-2.el7.noarch
---> Package saslwrapper.x86_64 0:0.16-5.el7 will be installed
--> Processing Dependency: /usr/bin/ruby for package: facter-2.4.1-1.el7.x86_64
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.6.2-3.el7.noarch
--> Finished Dependency Resolution
Error: Package: puppet-3.6.2-3.el7.noarch (epel)
           Requires: /usr/bin/ruby
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libruby.so.2.0()(64bit)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0(AUGEAS_0.12.0)(64bit)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0(AUGEAS_0.14.0)(64bit)
Error: Package: puppet-3.6.2-3.el7.noarch (epel)
           Requires: ruby(selinux)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0(AUGEAS_0.8.0)(64bit)
Error: Package: facter-2.4.1-1.el7.x86_64 (epel)
           Requires: /usr/bin/ruby
Error: Package: rubygem-rgen-0.6.6-2.el7.noarch (epel)
           Requires: ruby(rubygems)
Error: Package: ruby-shadow-1.4.1-23.el7.x86_64 (epel)
           Requires: ruby(release)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0(AUGEAS_0.1.0)(64bit)
Error: Package: 1:hiera-1.3.4-5.el7.noarch (epel)
           Requires: ruby(release)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0(AUGEAS_0.11.0)(64bit)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0()(64bit)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: augeas-libs >= 1.0.0
Error: Package: puppet-3.6.2-3.el7.noarch (epel)
           Requires: ruby(release)
Error: Package: facter-2.4.1-1.el7.x86_64 (epel)
           Requires: pciutils
Error: Package: puppet-3.6.2-3.el7.noarch (epel)
           Requires: ruby
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0(AUGEAS_0.10.0)(64bit)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: ruby(release)
Error: Package: ruby-augeas-0.5.0-1.el7.x86_64 (epel)
           Requires: libaugeas.so.0(AUGEAS_0.16.0)(64bit)
Error: Package: rubygem-rgen-0.6.6-2.el7.noarch (epel)
           Requires: ruby(release)
Error: Package: ruby-shadow-1.4.1-23.el7.x86_64 (epel)
           Requires: libruby.so.2.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

History

#1 Updated by Anonymous over 4 years ago

lmayorga1980 wrote:

I am trying to configure a new pulp-consumer on RHEL 7.x. Why there is a dependency on puppet package?

[...]

This ticket can be closed. I accidentally removed the RHEL subscription repositories

#2 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF