Project

Profile

Help

Issue #2072

changing yum distributor to not publish via http leaves broken symlink

Added by jsherril@redhat.com over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.8.4
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

changing a repo from serve via http from true to false results in a broken symlink:

pulp-admin rpm repo create --serve-http=true --repo-id=bar
pulp-admin rpm repo publish run --repo-id=bar
pulp-admin rpm repo update --serve-http=false --repo-id=bar
pulp-admin rpm repo publish run --repo-id=bar

notice broken symlink:

ls -l /var/lib/pulp/published/yum/http/repos/ -l

Not a huge issue, but exposed a bug in our yum_clone_distributor that was a bit tricky to track down, this can be worked around

History

#1 Updated by amacdona@redhat.com over 5 years ago

  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes

#2 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#3 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF