Project

Profile

Help

Issue #2068

HTTP 404: When trying to run yum update from a pulp-consumer

Added by Anonymous over 4 years ago. Updated 4 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.8.5
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I am trying to bind a pulp consumer to a specific repository and execute a simple yum update.

I get the following error.

...pulp/repos/content/dist/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

I also tried using curl -O from the same puppet server but it seems that the file is on the file-system and it was published correctly. When browsing from Chrome it just like the file is not there.


Since /var/lib/pulp is a symlink location then I have the following configuration file for pulp_content.conf.

<Location /pulp/content/>
    XSendFile on
    XSendFilePath /<mount_location>/content
    XSendFilePath /<mount_location>/pkg/published
    XSendFilePath /var/lib/pulp/content
    XSendFilePath /var/lib/pulp/published
</Location>

History

#1 Updated by dkliban@redhat.com over 4 years ago

I suspect that this is related to the SELinux problems you were experiencing in the other issue. Could you please reproduce this with SELinux in permissive mode?

#2 Updated by Anonymous over 4 years ago

wrote:

I suspect that this is related to the SELinux problems you were experiencing in the other issue. Could you please reproduce this with SELinux in permissive mode?

This is really strange since I was getting this error but after running pulp-manage-db for a second time and restarting httpd then it started to work again. Maybe it does some sort of indexing? or integrity checking?

#3 Updated by Anonymous over 4 years ago

lmayorga1980 wrote:

wrote:

I suspect that this is related to the SELinux problems you were experiencing in the other issue. Could you please reproduce this with SELinux in permissive mode?

This is really strange since I was getting this error but after running pulp-manage-db for a second time and restarting httpd then it started to work again. Maybe it does some sort of indexing? or integrity checking?

I have the problem again. This is my configuration for SELINUX

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=permissive
# SELINUXTYPE= can take one of three two values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected. 
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted 

#4 Updated by bmbouter over 4 years ago

Those SELinux configs are used at boot up. The best way to determine the current state of SELinux in a running environment is using `getenforce`.

Maybe discuss the issue some in #pulp to get the issue resolved faster?

#5 Updated by Anonymous over 4 years ago

bmbouter wrote:

Those SELinux configs are used at boot up. The best way to determine the current state of SELinux in a running environment is using `getenforce`.

Maybe discuss the issue some in #pulp to get the issue resolved faster?

$ getenforce
Permissive

Sure. Is this a IRC Channel?

#6 Updated by bmbouter over 4 years ago

Yes it's #pulp on Freenode [0].

[0]: https://freenode.net/

#7 Updated by amacdona@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

We suspect this is not a bug, feel free to reopen with more information if it continues to be an issue, and as mentioned earlier we are happy to help in #pulp on freenode.

#8 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#9 Updated by bmbouter 4 months ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF