Project

Profile

Help

Network maintenance. Planio will be observing two scheduled maintenance windows this Tuesday, March 2 and Wednesday, March 3 from 02:00 UTC until 06:00 UTC each in order to perform maintenance on access routers in our primary datacenter. Your account might observe short downtimes during these periods up to several minutes at a time.

Issue #2033

NOOP with more distributor doesn't work correctly

Added by jluza over 4 years ago. Updated almost 2 years ago.

Status:
CLOSED - NOTABUG
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Reproducer:
1. create repository with feed and sync
2. associate yum_distributor 1
2. associate yum_distributor 2
3. publish in distributor 1
4. list distributors associated with repository

result: last_published date is set for both distributors.

5. publish in distributor 2

result publish is NOOP

Probably caused by this line:
https://github.com/pulp/pulp/pull/2548/files#diff-cbbb6934093fcc95bf88815bb5d83aeaR1115

This line also needs to be fixed:
https://github.com/pulp/pulp/pull/2548/files#diff-cbbb6934093fcc95bf88815bb5d83aeaR1019

This bug also prevents testing rsync_distributor

History

#1 Updated by amacdona@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

#2 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF