Project

Profile

Help

Story #193

[RFE] consumer group CLI should support errata and package group install

Added by pthomas@redhat.com almost 6 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #969045 ++

Description of problem:

Description of problem:
Looks like there is no support for errata and package group install on consumer group.

Version-Release number of selected component (if applicable):

pulp-server-2.1.2-0.1.beta.el6.noarch
How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

--- Additional comment from at 05/30/2013 19:04:50 ---

Looks like the REST API is workig. CLI is missing though. Changing it for CLI

Here is POST for package group and errata install on consumer groups

pic.POST ('/v2/consumer_groups/consumer-grp/actions/content/install/',body={'units':[{'unit_key':{'name':'haskell'},'type_id':'package_group'}], 'options':{} })

pic.POST ('/v2/consumer_groups/consumer-grp/actions/content/install/',body={'units':[{'unit_key':{'id':'grinder_test_4'},'type_id':'erratum'}], 'options':{} })

--- Additional comment from at 06/05/2013 15:50:22 ---

Mike - I'm not sure this is a Katello blocker; it was recharacterized as a client only bug.

--- Additional comment from at 06/18/2013 22:14:43 ---

cleared sat6-blocker

History

#1 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

#2 Updated by bmbouter over 1 year ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF