Project

Profile

Help

Issue #1922

closed

unhandled exception when changing feed to equivalent repo

Added by mhrivnak over 6 years ago. Updated 12 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 15
Quarter:

Description

Given two pulp servers, A and B, that each have a repo with the same contents:

A third pulp server, C, syncs from that repo on A. The user changes the feed on C to point at B, and does another sync. The following exception occurs. In the case below, pulp C was 2.8.z. It's not certain what version of pulp was on A and B.

This was discovered by Satellite QE.

May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376) Exception caught from plugin during publish for repo [Default_Organization-Satellite_Capsule-Red_Hat_Satellite_Capsule_6_2_for_RHEL_6_Server_RPMs_x86_64]
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376) Traceback (most recent call last):
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 1023, in _do_publish
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     publish_report = publish_repo(transfer_repo, conduit, call_config)
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 658, in wrap_f
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     return f(*args, **kwargs)
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/distributors/yum/distributor.py", line 174, in publish_repo
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     return self._publisher.process_lifecycle()
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 562, in process_lifecycle
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     super(PluginStep, self).process_lifecycle()
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 159, in process_lifecycle
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     step.process()
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 249, in process
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     self._process_block()
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 293, in _process_block
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     self.process_main()
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 910, in process_main
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376)     os.symlink(timestamp_master_location, tmp_link_name)
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.controllers.repository:ERROR: (4648-37376) OSError: [Errno 17] File exists
May 17 13:23:26 cloud-qe-21 pulp: pulp.server.async.tasks:INFO: Task failed : [2df5545d-67fa-43f9-928a-e28795a7ac34]
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376) Task pulp.server.managers.repo.publish.publish[2df5545d-67fa-43f9-928a-e28795a7ac34] raised unexpected: OSError(17, 'File exists')
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376) Traceback (most recent call last):
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     R = retval = fun(*args, **kwargs)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 473, in __call__
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     return super(Task, self).__call__(*args, **kwargs)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in __call__
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     return super(PulpTask, self).__call__(*args, **kwargs)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 437, in __protected_call__
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     return self.run(*args, **kwargs)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 971, in publish
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     result = _do_publish(repo_obj, dist_id, dist_inst, transfer_repo, conduit, call_config)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 1023, in _do_publish
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     publish_report = publish_repo(transfer_repo, conduit, call_config)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 658, in wrap_f
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     return f(*args, **kwargs)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/distributors/yum/distributor.py", line 174, in publish_repo
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     return self._publisher.process_lifecycle()
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 562, in process_lifecycle
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     super(PluginStep, self).process_lifecycle()
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 159, in process_lifecycle
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     step.process()
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 249, in process
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     self._process_block()
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 293, in _process_block
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     self.process_main()
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 910, in process_main
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376)     os.symlink(timestamp_master_location, tmp_link_name)
May 17 13:23:26 cloud-qe-21 pulp: celery.worker.job:ERROR: (4347-37376) OSError: [Errno 17] File exists
Actions #1

Updated by mhrivnak over 6 years ago

  • Description updated (diff)
Actions #2

Updated by mhrivnak over 6 years ago

  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes
Actions #3

Updated by mhrivnak almost 6 years ago

  • Sprint/Milestone set to 32
Actions #4

Updated by bizhang almost 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bizhang
Actions #6

Updated by mhrivnak almost 6 years ago

  • Sprint/Milestone changed from 32 to 33
Actions #7

Updated by bizhang almost 6 years ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

Tried syncing repo over http + https from 2 pulp servers and could not reproduce on f24 with pulp 2.11.

Actions #8

Updated by bmbouter over 4 years ago

  • Sprint set to Sprint 15
Actions #9

Updated by bmbouter over 4 years ago

  • Sprint/Milestone deleted (33)
Actions #10

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF