Project

Profile

Help

Issue #1880

PLP0000: Update failed (The dotted field 'thomasmckay-rsync-0.4.1-thomasmckay'

Added by tomckay@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.8.3
Platform Release:
2.8.5
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 2
Quarter:

Description

Same symptoms as #1780 but occurs during tar.tz upload rather than repo sync. To reproduce, follow same steps but upload created tar.gz.

Associated revisions

Revision 529d2da9 View on GitHub
Added by ipanova@redhat.com over 4 years ago

Incorrect name when syncing puppet module from the filesystem.

closes #1879 closes #1880

https://pulp.plan.io/issues/1879 https://pulp.plan.io/issues/1880

History

#2 Updated by mhrivnak over 4 years ago

  • Priority changed from Normal to High
  • Sprint/Milestone set to 20
  • Triaged changed from No to Yes

#3 Updated by ipanova@redhat.com over 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#4 Updated by ipanova@redhat.com over 4 years ago

I was not able to reproduce this issue during puppet module upload.

$ cat metadata.json
{
  "name": "thomasmckay-rsync",
  "version": "0.4.0",
  "author": "thomasmckay",
  "summary": "Manages rsync clients, repositories, and servers, & providies defines to easily grab data via rsync.",
  "license": "Apache-2.0",
  "source": "https://github.com/thomasmckay/thomasmckay-rsync",
  "project_page": "https://github.com/thomasmckay/thomasmckay-rsync",
  "issues_url": "https://tickets.thomasmckay.com/browse/MODULES",
  "dependencies": [
    {"name":"thomasmckay/stdlib","version_requirement":">=4.2.0"},
    {"name":"thomasmckay/xinetd","version_requirement":">=1.1.0"},
    {"name":"thomasmckay/concat","version_requirement":">= 1.1.1"}
  ]
}
$ pulp-admin puppet repo uploads upload --repo-id test-repo --file /var/www/html/pub/puppet-modules/thomasmckay-rsync-0.4.0.tar.gz

+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: thomasmckay-rsync-0.4.0.tar.gz
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: thomasmckay-rsync-0.4.0.tar.gz
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
canceled entirely using the cancel command.

Uploading: thomasmckay-rsync-0.4.0.tar.gz
[==================================================] 100%
11208/11208 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Succeeded

Deleting the upload request...
... completed

$ pulp-admin puppet repo modules --repo-id test-repo

Name:               thomasmckay-rsync
Version:            0.4.0
Author:             thomasmckay
Checksum:           c2cafab503175efa503a91abd9157127ae6115be72393ebebdb2a6a00426
                    1794
Checksum Type:      sha256
Dependencies:       
  Name:                thomasmckay/stdlib
  Version Requirement: >=4.2.0
  Name:                thomasmckay/xinetd
  Version Requirement: >=1.1.0
  Name:                thomasmckay/concat
  Version Requirement: >= 1.1.1
Downloaded:         True
License:            Apache-2.0
Project Page:       https://github.com/thomasmckay/thomasmckay-rsync
Pulp User Metadata: 
Source:             https://github.com/thomasmckay/thomasmckay-rsync
Summary:            Manages rsync clients, repositories, and servers, &
                    providies defines to easily grab data via rsync.
Tag List:   

#5 Updated by ipanova@redhat.com over 4 years ago

Most likely it was fixed with this fix https://pulp.plan.io/issues/1780

#6 Updated by ipanova@redhat.com over 4 years ago

  • Status changed from ASSIGNED to 5

seems like PR https://github.com/pulp/pulp_puppet/pull/224 also fixed the upload of puppet module. Thomas was not able to reproduce this issue anymore.

#7 Updated by ipanova@redhat.com over 4 years ago

  • Status changed from 5 to ASSIGNED

#8 Updated by ipanova@redhat.com over 4 years ago

  • Status changed from ASSIGNED to POST

this PR fix for #1879 should also fix this issue https://github.com/pulp/pulp_puppet/pull/230

#9 Updated by ipanova@redhat.com over 4 years ago

Steps to reproduce:

1) sync from filesystem puppet module foo into repo bar
2) upload same module foo into repo bar

Try to publish.

$ pulp-admin puppet repo publish run --repo-id=modules

+----------------------------------------------------------------------+
                    Publishing Repository [modules]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Task Failed

Update failed (not okForStorage)

#10 Updated by ipanova@redhat.com over 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#11 Updated by ipanova@redhat.com over 4 years ago

  • Platform Release set to 2.8.4

#12 Updated by semyers over 4 years ago

  • Status changed from MODIFIED to 5

#13 Updated by semyers over 4 years ago

  • Platform Release changed from 2.8.4 to 2.8.5

#14 Updated by semyers over 4 years ago

  • Status changed from 5 to MODIFIED

#15 Updated by pthomas@redhat.com over 4 years ago

  • Status changed from MODIFIED to 6

verified


[root@cloud-qe-14 ~]# rpm -qa pulp-puppet
[root@cloud-qe-14 ~]# rpm -qa |grep pulp-puppet
python-pulp-puppet-common-2.8.4-0.1.beta.el7.noarch
pulp-puppet-admin-extensions-2.8.4-0.1.beta.el7.noarch
pulp-puppet-plugins-2.8.4-0.1.beta.el7.noarch
pulp-puppet-tools-2.8.4-0.1.beta.el7.noarch
[root@cloud-qe-14 ~]# 

[root@cloud-qe-14 puppetlabs-rsync]# pulp-admin puppet repo uploads upload --repo-id puppet-upload --file /var/www/html/pub/puppet-modules/thomasmckay-rsync-0.4.0.tar.gz
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: thomasmckay-rsync-0.4.0.tar.gz
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: thomasmckay-rsync-0.4.0.tar.gz
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
canceled entirely using the cancel command.

Uploading: thomasmckay-rsync-0.4.0.tar.gz
[==================================================] 100%
10403/10403 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Succeeded

Deleting the upload request...
... completed

[root@cloud-qe-14 puppetlabs-rsync]# pulp-admin puppet repo publish run --repo-id puppet-upload
+----------------------------------------------------------------------+
                 Publishing Repository [puppet-upload]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Publishing modules...
[==================================================] 100%
Module: 1/1 items
... completed

Generating repository metadata...
[-]
... completed

Publishing repository over HTTP...
... completed

Publishing repository over HTTPS...
... skipped

Task Succeeded

#16 Updated by semyers over 4 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#18 Updated by bmbouter over 2 years ago

  • Sprint set to Sprint 2

#19 Updated by bmbouter over 2 years ago

  • Sprint/Milestone deleted (20)

#20 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF