Project

Profile

Help

Issue #1822

closed

Pulp 2.8 client no longer supports sha1 RPM checksum type (REOPEN #1802)

Added by esabouraud about 6 years ago. Updated about 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.8.0
Platform Release:
OS:
RHEL 6
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I am indeed able to reproduce the issue, please see the attached verbose upload logs.

This looks like a webservice API compatibility issue to me : checksum_type has been changed to checksumtype.

On the server side, the version is 2.7.0-1.el6. As a user, I only updated my client from 2.7.1 to 2.8.1.

pulp-admin 2.7.1-1.el6:

2016-04-06 18:21:41,640 - INFO - POST request to /pulp/api/v2/repositories/ingenico-front-dev-el6-x86_64/actions/import_upload/ with parameters {"override_config": {}, "unit_type_id": "rpm", "upload_id": "2a96d0b2-ac9b-4fab-83ea-2a09180b98e4", "unit_key": {}, "unit_metadata": {"checksum_type": "sha1"}}

pulp-admin 2.8.1-1.el6:

2016-04-06 18:26:53,233 - INFO - POST request to /pulp/api/v2/repositories/ingenico-front-dev-el6-x86_64/actions/import_upload/ with parameters {"override_config": {}, "unit_type_id": "rpm", "upload_id": "10902836-d915-4cff-a7af-df39e7d2aed6", "unit_key": {}, "unit_metadata": {"checksumtype": "sha1"}}

Files

pulp27-uploadsha1rpm.txt (6.18 KB) pulp27-uploadsha1rpm.txt upload with pulp-admin-client-2.7.1-1 esabouraud, 04/06/2016 06:50 PM
pulp28-uploadsha1rpm.txt (6.21 KB) pulp28-uploadsha1rpm.txt upload with pulp-admin-client-2.8.1-1 esabouraud, 04/06/2016 06:50 PM

Related issues

Is duplicate of Pulp - Issue #1802: Pulp 2.8 client no longer supports sha1 RPM checksum typeCLOSED - CURRENTRELEASEjortel@redhat.comActions
Actions #1

Updated by mhrivnak about 6 years ago

  • Is duplicate of Issue #1802: Pulp 2.8 client no longer supports sha1 RPM checksum type added
Actions #2

Updated by mhrivnak about 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #3

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF