Project

Profile

Help

Issue #1814

Vague error messages with sync.

Added by mohammed.zee1000@gmail.com over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version - Docker:
2.0.0
Platform Release:
Target Release - Docker:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Hi,

I was attempting to sync an image on a private docker distribution registry with pulp. 

I was getting "Could not find registry API at https://url:port" even though i was able to successfully pull images from the exact same url. With the help of mhrivnak, I was able to trace the error to an SSL certificate issue ie pulp did not recognize the self signed ssl certificate of the registry which was setup on the pulp-admin client sitting on a different node.

With the error message itself, it is difficult to pinpoint the fact that the error was due to the certificate problem.

History

#1 Updated by mhrivnak over 5 years ago

  • Project changed from Pulp to Docker Support
  • Severity changed from 2. Medium to 1. Low
  • Version - Docker set to 2.0.0
  • Triaged changed from No to Yes

#2 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#3 Updated by bmbouter over 2 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF