Project

Profile

Help

Story #181

closed

RFE: sync status listing for all repositories

Added by jperrin@centos.org over 7 years ago. Updated about 3 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #955176 ++

Description of problem:

Description of problem:
There is currently no way to quickly determine the sync status of rpm repositories.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. create repos in pulp.
2. try to return just repo id, and last sync/publish times using --fields.
3. fail miserably.

Actual results:
There's no way to filter on last sync or last publish currently.

Expected results:
some method to just show repo id, and last sync/publish times without resorting to terrible shell hacks.

Additional info:
Promised jdob firstborn child if he makes this happen. He seemed insistent that the contract be signed in blood.

--- Additional comment from at 04/22/2013 19:51:14 ---

The complication here is that the render_document_list method will only apply the filter to top-level keys. The sync/publish keys are deeper in the doc tree under the importer and distributor respectively. The solution might be to refine that to allow denoting filters at a deeper level.

The problem is that the user experience would kinda suck since they'd need to know to specify something like importer.last_sync. So it may be that the answer is to support this view explicitly.

Actions #1

Updated by bmbouter about 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX
Actions #2

Updated by bmbouter about 3 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

Actions #3

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF