Project

Profile

Help

Issue #1805

Compressed Groups Not Working With Mirror of Fedora 23

Added by jcape over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
High
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.8.0
Platform Release:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Server is C72, upgraded 2.4 -> 2.6 -> 2.8rc9 -> 2.8, but not in production yet.

The public Fedora 23 mirrors use lzma compression for group_gz in repomod, i.e. *-comps.xml.xz.

When pulp syncs a repo, it reads comps from somewhere (it looks like the .xz should work), and it output the uncompressed *-comps.xml file as the type="group" data, and ignores group_gz altogether in the published repomd.xml. Unfortunately, in Fedora 23, Yum is deprecated, and DNF/libcomps does not handle uncompressed comps data. So Pulp won't publish compressed + DNF won't read uncompressed = no groups for F23 dnf users.

One thing I notice is that a mirror of Adobe's x86_64 repo keeps the type="group_gz" data, albeit as comps.xml.gz (which just has an empty comps tag). It goes a step further, because while trying to hack around the DNF limitation I changed the "comps.xml" in the distributor python to use "comps.xml.gz", which humorously caused the adobe repo to start using "comps.xml.gz.gz". I've also tried the other obvious naive approach: adding various endswith('.xz') alongside the endswith('.gz').

Mostly, this has served to confirm that I don't know how this stuff is supposed to be working.

Anyways, if someone could clue me in, that would be awesome---my further naive thought is that it should simply always output group_gz, regardless of whether upstream includes it or not.

History

#1 Updated by jcape over 4 years ago

(The upshot is that I can do the work to make this go, but I'm at a loss as to why it kinda-sorta works for certain things now.)

#2 Updated by jcape over 4 years ago

The kinda-sorta-works is caused by ---generate-sqlite, which overwrites all the metadata output pulp is generating, and also creates the comps.xml.gz file. I'd still like to work on getting pulp itself to output group_gz by default, if someone can give me pointers.

#3 Updated by mhrivnak over 4 years ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes

#4 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF