Project

Profile

Help

Issue #1800

Downloaded/synced packages are not published.

Added by akegata@gmail.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.6.1
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I'm syncing the pulp repo (https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/6Server/x86_64/).
A pulp-admin rpm repo sync run --repo-id run of the repo seemingly works fine, no errors are shown.
However, a number of rpm's are not published, specifically the rpms for pulp 2.8.x in this case.

  1. rpm -qa | grep pulp-server
    pulp-server-2.6.2-1.el6.noarch

The package exists in /var/lib/pulp/content/rpm/pulp-server/, but there is no symlink in /var/lib/pulp/published/yum/master/yum_distributor for the package.

History

#1 Updated by ipanova@redhat.com over 4 years ago

I used 1 repo and used 2 feeds - was not able to reproduce the situation. Symlinks are created. Used pulp 2.6.1

# pulp-admin -uadmin -p admin rpm repo create --repo-id pulp27 --feed https://repos.fedorapeople.org/repos/pulp/pulp/stable/2.7/6Server/x86_64/
Successfully created repository [pulp27]

# pulp-admin -uadmin -p admin rpm repo sync run --repo-id pulp27
+----------------------------------------------------------------------+
                   Synchronizing Repository [pulp27]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[|]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       82/82 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Task Succeeded

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
82 of 82 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[-]
... completed

Publishing Comps file
[==================================================] 100%
7 of 7 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

# pulp-admin -uadmin -p admin rpm repo update --repo-id pulp27 --feed https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/6Server/x86_64/
Repository [pulp27] successfully updated

# pulp-admin -uadmin -p admin rpm repo sync run --repo-id pulp27
+----------------------------------------------------------------------+
                   Synchronizing Repository [pulp27]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[|]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       56/56 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Task Succeeded

Copying files
[-]
... completed

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
56 of 56 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[-]
... completed

Publishing Comps file
[==================================================] 100%
7 of 7 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

# ll /var/lib/pulp/published/yum/https/repos/repos/pulp/pulp/stable/2.7/6Server/x86_64/pulp-server-*
lrwxrwxrwx. 1 apache apache 156 Mar 31 06:30 /var/lib/pulp/published/yum/https/repos/repos/pulp/pulp/stable/2.7/6Server/x86_64/pulp-server-2.7.1-1.el6.noarch.rpm -> /var/lib/pulp/content/rpm/pulp-server/2.7.1/1.el6/noarch/dc78ea6d70b73b65ee7592d690970d3b9869686a75e52bf50e54ec5836a3c2a2/pulp-server-2.7.1-1.el6.noarch.rpm
lrwxrwxrwx. 1 apache apache 156 Mar 31 06:30 /var/lib/pulp/published/yum/https/repos/repos/pulp/pulp/stable/2.7/6Server/x86_64/pulp-server-2.8.0-1.el6.noarch.rpm -> /var/lib/pulp/content/rpm/pulp-server/2.8.0/1.el6/noarch/ac6cc24adf7b919e4897579fc0553ad0ddfa38e493dc903f786b00ea92a67a21/pulp-server-2.8.0-1.el6.noarch.rpm

#2 Updated by akegata@gmail.com over 4 years ago

I removed the folder for the repo in /var/lib/pulp/published/yum/master/yum_distributor/ and did a resync. The pulp 2.8 rpm's are now published, so the issue is solved on my end.
I am also unsure if I will be able to recreate the issue for further testing since I have only seen this happen on this specific repo.

#3 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to CLOSED - WORKSFORME

Please re-open if you are able to reproduce.

#4 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF