Project

Profile

Help

Issue #1772

Error migrating to 2.8 beta 0025_export_relative_url.py throws KeyError: 'repo_id'

Added by jsherril@redhat.com over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Katello user upgrading from pulp 2.6.5 to Pulp 2.8.0-0.5.beta hit this error during the migration:

Halting migrations due to a migration failure.
'repo_id'
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 193, in main
return _auto_manage_db(options)
File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 256, in _auto_manage_db
migrate_database(options)
File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 124, in migrate_database
update_current_version=not options.test)
File "/usr/lib/python2.7/site-packages/pulp/server/db/migrate/models.py", line 186, in apply_migration
migration.migrate()
File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0025_export_relative_url.py", line 60, in migrate
distributors = list(repo_distributors.find({'repo_id': repo_object['repo_id']}))
KeyError: 'repo_id'

Related katello issue:
http://projects.theforeman.org/issues/14171

Hopefully this is a known issue but a quick search showed nothing


Related issues

Is duplicate of Pulp - Issue #1753: Errors migrating pulp after upgrading katello 2.4 to 3.0CLOSED - WORKSFORME<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jsherril@redhat.com over 5 years ago

  • Description updated (diff)

#2 Updated by dkliban@redhat.com over 5 years ago

  • Is duplicate of Issue #1753: Errors migrating pulp after upgrading katello 2.4 to 3.0 added

#3 Updated by mhrivnak over 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF