Project

Profile

Help

Issue #1729

cannot retrieve kernel/initrd from pulp after on_demand sync

Added by jsherril@redhat.com over 5 years ago. Updated about 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Syncing a kickstart tree does not download kernel and initrd.

Downloading any of these repos from the cdn:

RHEL 7.2 x86_64
RHEL 6.7 x86_64
RHEL 7.1 x86_64

All of them are missing their ./images/pxeboot/vmlinuz and ./images/pxebooot/initrd.img files

there may be more files missing, i just noticed these.

pulp-server-2.8.0-0.5.beta.el7.noarch

treeinfo (2.09 KB) treeinfo jsherril@redhat.com, 02/29/2016 08:47 PM

History

#1 Updated by jsherril@redhat.com over 5 years ago

I also would not eliminate the possibility of it being a cdn issue, i just could not see one off the bat.

#5 Updated by jsherril@redhat.com over 5 years ago

Its also possible that this is lazy related, but when fetching it, i get:


jlsherri~$ curl -X GET http://robot.example.com/pulp/repos/Default_Organization/Library/content/dist/rhel/server/6/6.6/x86_64/kickstart/images/pxeboot/vmlinuz
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /pulp/repos/Default_Organization/Library/content/dist/rhel/server/6/6.6/x86_64/kickstart/images/pxeboot/vmlinuz
on this server.</p>
</body></html>

#6 Updated by jsherril@redhat.com over 5 years ago

Apache error while trying to fetch:

[Mon Feb 29 15:04:31.870142 2016] [core:error] [pid 1367] [client 192.168.121.1:52418] AH00037: Symbolic link not allowed or link target not accessible: /var/www/pub/yum/http/repos/Default_Organization/Library/content/dist/rhel/server/6/6.6/x86_64/kickstart/images/pxeboot/vmlinuz

I also get the same error when attempting to fetch an rpm:

52404] AH00037: Symbolic link not allowed or link target not accessible: /var/www/pub/yum/http/repos/Default_Organization/Library/content/dist/rhel/server/6/6.6/x86_64/kickstart/Packages/man-pages-it-2.80-6.el6.noarch.rpm

#7 Updated by jsherril@redhat.com over 5 years ago

find of my distributions:

[root@robot ~]# find /var/lib/pulp/content/units/distribution/*
/var/lib/pulp/content/units/distribution/49
/var/lib/pulp/content/units/distribution/49/da05e1e526ca2cefec9985aea4c85ba2d1a04e167ecf1acbe50b0063fc30c9
/var/lib/pulp/content/units/distribution/49/da05e1e526ca2cefec9985aea4c85ba2d1a04e167ecf1acbe50b0063fc30c9/treeinfo
/var/lib/pulp/content/units/distribution/ac
/var/lib/pulp/content/units/distribution/ac/adf6ece38c7e46bee6a2a96b14a6a231010a9b2ad083383321e29cd7d96db2
/var/lib/pulp/content/units/distribution/ac/adf6ece38c7e46bee6a2a96b14a6a231010a9b2ad083383321e29cd7d96db2/treeinfo
/var/lib/pulp/content/units/distribution/b0
/var/lib/pulp/content/units/distribution/b0/e4ccbd9be034fe7bafa778d06fdf2a7fee847612e91a01bb27023e800b06e2
/var/lib/pulp/content/units/distribution/b0/e4ccbd9be034fe7bafa778d06fdf2a7fee847612e91a01bb27023e800b06e2/treeinfo

#8 Updated by mhrivnak over 5 years ago

I'm not able to reproduce using an internal mirror. The sync of the RHEL 7.2 kickstart repo retrieved 6 files.

$ pwd
/var/lib/pulp/content/units/distribution
$ tree
.
├── 49
│   └── da05e1e526ca2cefec9985aea4c85ba2d1a04e167ecf1acbe50b0063fc30c9
│       ├── addons
│       │   ├── HighAvailability
│       │   │   └── repodata
│       │   │       └── repomd.xml
│       │   └── ResilientStorage
│       │       └── repodata
│       │           └── repomd.xml
│       ├── images
│       │   └── pxeboot
│       │       ├── initrd.img
│       │       ├── upgrade.img
│       │       └── vmlinuz
│       ├── LiveOS
│       │   └── squashfs.img
│       └── treeinfo
└── de
    └── d64602f1a2165af46f6cd4c8c2645a0422607173fb34617458c9f419e2c7bf

#10 Updated by mhrivnak over 5 years ago

  • Subject changed from syncing kickstart tree ignores kernel/initrd to cannot retrieve kernel/initrd from pulp after on_demand sync

#11 Updated by jsherril@redhat.com over 5 years ago

  • Status changed from NEW to CLOSED - NOTABUG

turned out this was an old config in /etc/pulp/vhosts80/rpm.conf

#12 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF