Project

Profile

Help

Issue #1725

Packages attribute miscalculation in repodata xml files

Added by pcreech almost 5 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Master
Platform Release:
2.8.0
OS:
Fedora 23
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

It was discovered that during subsequent publishes of a repository that hasn't changed, the packages attribute in the root element gets 'updated' in the repodata/{filelist,other,primary}.xml files to a 0.

This leads us to not being able to consistently generate identical data on a repeatable action (i.e. first publish, subsequent publishes)

I'm also curious as what this value would end up being with an extra package added.

Steps to reproduce:

pulp-admin rpm repo create --repo-id=zoo --feed=https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
pulp-admin rpm repo sync run --repo-id=zoo

Take note of the data in repomd.xml (Specifically size, and open-size)
Gunzip the filelist.xml,other.xml and primary.xml files and take note of the root element attribute 'packages' (should be 32, at current state of zoo repo)

pulp-admin rpm repo publish run --repo-id=zoo

Take note of the data in repomd.xml (Specifically size, and open-size)
Gunzip the filelist.xml,other.xml and primary.xml files and take note of the root element attribute 'packages' (is now 0)

repomod.xml open-size attributes should be off by one byte less as well (in this case, since we are going from a two digit number to a one digit number)
Package elements still exists in the files

I am currently unaware of anything that relies on the packages attribute, as well as it's significance. But it does reflect a curious miss-counting issue here.

I've attached a diff showing the difference in the files.

repodata.diff (5.43 KB) repodata.diff pcreech, 02/26/2016 10:39 PM

Associated revisions

Revision 3b8e9d34 View on GitHub
Added by mhrivnak almost 5 years ago

Fixes unit count in pulished metadata on publish of unchanged repo

https://pulp.plan.io/issues/1725

fixes #1725

History

#1 Updated by mhrivnak almost 5 years ago

This appears to be a regression. I'm not able to reproduce on 2.7.1.

#2 Updated by mhrivnak almost 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to mhrivnak
  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 1. Low

#3 Updated by mhrivnak almost 5 years ago

  • Status changed from ASSIGNED to POST
  • Triaged changed from No to Yes

#4 Updated by mhrivnak almost 5 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#5 Updated by mhrivnak almost 5 years ago

  • Platform Release set to 2.8.0

#6 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from MODIFIED to 5

#7 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF